Skip to content
Laskyr

Plugins · worker · data as of 2026-11-01

Is ManageWP Worker safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.9.38)

As of 2026-11-01. 3 issues are on record for older versions; version 4.9.37 or newer fixes all of them that state a fix.

Latest version
4.9.38
Last updated
2026-08-21
Active installs
1+ million
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4

A better way to manage dozens of WordPress websites. — by ManageWP

What to do

  1. Update to the latest version (4.9.38). Anything older than 4.9.37 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get worker --field=version shows what you run; wp plugin update worker updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.1 CVE-2026-18052 · published 2026-08-22

Authentication bypass in ManageWP Worker (older than 4.9.37)

Affected
older than 4.9.37
Fixed in
4.9.37
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The ManageWP Worker WordPress plugin before 4.9.37 does not bind the account being logged in to the signature which authorises the login, nor prevent an already used login link from being replayed, allowing attackers who obtain such a link to gain a session as any user on the site, including an administrator.

NVD CVE-2026-18052WPScan advisory

high 7.1 CVE-2026-39463 · published 2026-06-15

Cross-site scripting (XSS) in ManageWP Worker (4.9.31 and older)

Affected
4.9.31 and older
Fixed in
4.9.32
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in ManageWP Worker <= 4.9.31 versions.

NVD CVE-2026-39463Patchstack advisory

high 7.2 CVE-2026-3718 · published 2026-05-14

Stored cross-site scripting (XSS) in ManageWP Worker (4.9.31 and older)

Affected
4.9.31 and older
Fixed in
4.9.32 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ManageWP Worker plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'MWP-Key-Name' HTTP request header in all versions up to, and including, 4.9.31. This is due to insufficient input sanitization and output escaping of attacker-controlled header values. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever an administrator visits the plugin's connection management page with debug parameters.

NVD CVE-2026-3718Wordfence advisoryCode change (fix)

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ManageWP Worker vulnerability status badge
<a href="https://laskyr.com/plugins/worker"><img src="https://laskyr.com/plugins/worker/badge.svg" alt="ManageWP Worker vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit