Skip to content
Laskyr

Plugins · wordpress-importer · data as of 2026-11-01

Is WordPress Importer safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (0.9.7)

As of 2026-11-01. 1 issue is on record for older versions; version 0.8.4 or newer fixes all of them that state a fix.

Latest version
0.9.7
Last updated
2026-10-20
Active installs
2+ million
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.8.12 · PHP 7.2+

Import posts, pages, comments, custom fields, categories, tags and more from a WordPress export file. — by WordPress.org

What to do

  1. Update to the latest version (0.9.7). Anything older than 0.8.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wordpress-importer --field=version shows what you run; wp plugin update wordpress-importer updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2024-13889 · published 2025-03-26

PHP object injection in WordPress Importer (0.8.3 and older)

Affected
0.8.3 and older
Fixed in
0.8.4 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WordPress Importer plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 0.8.3 via deserialization of untrusted input in the 'maybe_unserialize' function. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present.

NVD CVE-2024-13889Wordfence advisoryCode change (fix)Plugin source

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WordPress Importer vulnerability status badge
<a href="https://laskyr.com/plugins/wordpress-importer"><img src="https://laskyr.com/plugins/wordpress-importer/badge.svg" alt="WordPress Importer vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit