Plugins · wordlift · data as of 2026-11-04
Is WordLift safe? Known vulnerabilities and latest version
- Latest version
- 3.54.18
- Last updated
- 2026-10-20
- Active installs
- 300+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Search engines are looking for meaning, not keywords. WordLift tells Google how your content relates to your brand, products, and stakeholders. — by WordLift
What to do
- Update to the latest version (3.54.18). Anything older than 3.54.17 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wordlift --field=version shows what you run; wp plugin update wordlift updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2026-110891 · published 2026-10-15
Missing authorization check in WordLift (3.54.15 and older)
- Affected
- 3.54.15 and older
- Fixed in
- 3.54.17
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WordLift Srl WordLift wordlift allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WordLift: from n/a through 3.54.15.
medium 5.3 CVE-2026-9289 · published 2026-09-19
Information disclosure in WordLift (3.54.10 and older)
- Affected
- 3.54.10 and older
- Fixed in
- 3.54.11 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WordLift – AI powered SEO – Schema plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.54.10 via the JSON-LD REST API endpoints. This is due to the plugin registering the /wordlift/v1/jsonld/ routes (jsonld/{id}, jsonld/http/{item_id}, jsonld/post-meta/{meta_key}, jsonld/meta/{meta_key}, and jsonld/{post_type}/{post_name}) with a permission_callback of '__return_true' and the downstream converter retrieving the post via get_post() without verifying the post status or the requesting user's capabilities. This makes it possible for unauthenticated attackers to read the title, content/description, author, publication and modification dates, word count, comment count, and other metadata of private, draft, and pending posts by enumerating post IDs, bypassing WordPress core access controls.
NVD CVE-2026-9289Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2025-53582 · published 2025-08-14
Stored cross-site scripting (XSS) in WordLift (3.54.5 and older)
- Affected
- 3.54.5 and older
- Fixed in
- 3.54.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WordLift WordLift wordlift allows Stored XSS.This issue affects WordLift: from n/a through <= 3.54.5.
medium 4.3 CVE-2025-30624 · published 2025-06-06
Missing authorization check in WordLift (3.54.4 and older)
- Affected
- 3.54.4 and older
- Fixed in
- 3.54.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WordLift WordLift wordlift allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WordLift: from n/a through <= 3.54.4.
medium 5.3 CVE-2024-12176 · published 2025-01-07
Missing authorization check in WordLift (3.54.2 and older)
- Affected
- 3.54.2 and older
- Fixed in
- 3.54.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WordLift – AI powered SEO – Schema plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the 'wl_config_plugin' AJAX action in all versions up to, and including, 3.54.2. This makes it possible for unauthenticated attackers to update the plugin's settings.
medium 4.8 CVE-2022-3069 · published 2022-09-26
Cross-site scripting (XSS) in WordLift (older than 3.37.2)
- Affected
- older than 3.37.2
- Fixed in
- 3.37.2
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The WordLift WordPress plugin before 3.37.2 does not sanitise and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Recent activity
- 2026-10-20 — latest release on wordpress.org (3.54.18).
- 2026-10-15 — Missing authorization check disclosed (CVE-2026-110891), fixed in 3.54.17.
- 2026-09-19 — Information disclosure disclosed (CVE-2026-9289), fixed in 3.54.11.
- 2025-08-14 — Stored cross-site scripting (XSS) disclosed (CVE-2025-53582), fixed in 3.54.6.
Get an email when WordLift has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WordLift (wordlift) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (3) · Cross-site scripting (XSS) (2) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wordlift (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wordlift"><img src="https://laskyr.com/plugins/wordlift/badge.svg" alt="WordLift vulnerability status"></a>