Skip to content
Laskyr

Plugins · wordfence · data as of 2026-11-01

Is Wordfence Security safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (9.0.2)

As of 2026-11-01. 2 issues are on record for older versions; version 7.6.1 or newer fixes all of them that state a fix.

Latest version
9.0.2
Last updated
2026-09-30
Active installs
5+ million
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Firewall, Malware Scanner, Two Factor Auth, and Comprehensive Security Features, powered by our 24-hour team. Make security a priority with Wordfence. — by Mark Maunder

What to do

  1. Update to the latest version (9.0.2). Anything older than 7.6.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wordfence --field=version shows what you run; wp plugin update wordfence updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.8 CVE-2022-3144 · published 2022-09-23

Stored cross-site scripting (XSS) in Wordfence Security (7.6.0 and older)

Affected
7.6.0 and older
Fixed in
7.6.1 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Wordfence Security – Firewall & Malware Scan plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to and including 7.6.0 via a setting on the options page due to insufficient escaping on the stored value. This makes it possible for authenticated users, with administrative privileges, to inject malicious web scripts into the setting that executes whenever a user accesses a page displaying the affected setting on sites running a vulnerable version.

NVD CVE-2022-3144Wordfence advisoryCode change (fix)wordpress.orgWordfence advisory

medium 4.3 CVE-2014-4664 · published 2014-11-06

Cross-site scripting (XSS) in Wordfence Security (older than 5.1.4)

Affected
older than 5.1.4
Fixed in
5.1.4
Range from
advisory text · score by NVD
Details from the advisory

Cross-site scripting (XSS) vulnerability in the Wordfence Security plugin before 5.1.4 for WordPress allows remote attackers to inject arbitrary web script or HTML via the whoisval parameter on the WordfenceWhois page to wp-admin/admin.php.

NVD CVE-2014-4664wordpress.orghacktivity.websecgeeks.comsecurityfocus.comsecurityfocus.comsecurityfocus.comWordfence advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Wordfence Security vulnerability status badge
<a href="https://laskyr.com/plugins/wordfence"><img src="https://laskyr.com/plugins/wordfence/badge.svg" alt="Wordfence Security vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit