Plugins · woowbot-woocommerce-chatbot · data as of 2026-11-04
Is AI ChatBot for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 5.0.3
- Last updated
- 2026-10-27
- Active installs
- 900+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
AI chatbot for WooCommerce. Automate support, Increase WooCommerce Sales. AI TryOn, AI Business Analysis. ChatGPT, Gemini. Boost Engagement No Coding! — by QuantumCloud
What to do
- Update to the latest version (5.0.3). Anything older than 5.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woowbot-woocommerce-chatbot --field=version shows what you run; wp plugin update woowbot-woocommerce-chatbot updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-111372 · published 2026-10-28
Missing authorization check in AI ChatBot for WooCommerce (5.0.0 and older)
- Affected
- 5.0.0 and older
- Fixed in
- 5.0.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The AI ChatBot for WooCommerce – WoowBot plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 5.0.0. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to repeatedly trigger RAG document sync operations that issue paid embedding API calls to OpenAI, Gemini, OpenRouter, or xAI charged to the site administrator's stored API key, draining their AI API credits and causing financial loss. The wp_chatbot nonce required to reach this endpoint is emitted to every authenticated frontend visitor via wp_localize_script, making it trivially obtainable by any subscriber-level account.
high 7.5 CVE-2026-15241 · published 2026-08-02
Missing authorization check in AI ChatBot for WooCommerce (older than 4.8.4)
- Affected
- older than 4.8.4
- Fixed in
- 4.8.4
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The AI ChatBot for WooCommerce WordPress plugin before 4.8.4 does not perform any authorization or nonce check on one of its AJAX actions, allowing unauthenticated users to abuse the site owner's stored third-party API key to send requests billed to the owner's account and, when an optional feature is enabled, to retrieve indexed knowledge-base content.
medium 6.5 CVE-2026-57414 · published 2026-07-13
Stored cross-site scripting (XSS) in AI ChatBot for WooCommerce (4.6.1 and older)
- Affected
- 4.6.1 and older
- Fixed in
- 4.7.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in QuantumCloud ChatBot for eCommerce – WoowBot woowbot-woocommerce-chatbot allows Stored XSS.This issue affects ChatBot for eCommerce – WoowBot: from n/a through <= 4.6.1.
Recent activity
- 2026-10-27 — latest release on wordpress.org (5.0.3).
- 2026-10-28 — Missing authorization check disclosed (CVE-2026-111372), fixed in 5.0.1.
- 2026-08-02 — Missing authorization check disclosed (CVE-2026-15241), fixed in 4.8.4.
- 2026-07-13 — Stored cross-site scripting (XSS) disclosed (CVE-2026-57414), fixed in 4.7.0.
Get an email when AI ChatBot for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for AI ChatBot for WooCommerce (woowbot-woocommerce-chatbot) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by QuantumCloud (5 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woowbot-woocommerce-chatbot (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woowbot-woocommerce-chatbot"><img src="https://laskyr.com/plugins/woowbot-woocommerce-chatbot/badge.svg" alt="AI ChatBot for WooCommerce vulnerability status"></a>