Plugins · woostify-sites-library · data as of 2026-11-04
Is Woostify Sites Library safe? Known vulnerabilities and latest version
- Latest version
- 1.6.2
- Last updated
- 2026-03-13
- Active installs
- 10,000+
- Known issues on record
- 2
- Unpatched in latest
- 1
- Tested up to WP
- 6.9.11 · PHP 7.0+
A collection of simple, beautiful demo sites for Woostify. — by dylan ngo
What to do
- There is no fixed version yet. If you can live without Woostify Sites Library for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get woostify-sites-library --field=version shows what you run; wp plugin update woostify-sites-library updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 affects latest 1.6.2 CVE-2025-66076 · published 2026-07-02
Missing authorization check in Woostify Sites Library (1.6.2 and older)
- Affected
- 1.6.2 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in Woostify Sites Library <= 1.6.2 versions.
high 7.1 CVE-2023-6279 · published 2024-01-29
Denial of service in Woostify Sites Library (older than 1.4.8)
- Affected
- older than 1.4.8
- Fixed in
- 1.4.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Woostify Sites Library WordPress plugin before 1.4.8 does not have authorisation in an AJAX action, allowing any authenticated users, such as subscriber to update arbitrary blog options and set them to 'activated' which could lead to DoS when using a specific option name
Recent activity
- 2026-03-13 — latest release on wordpress.org (1.6.2).
- 2026-07-02 — Missing authorization check disclosed (CVE-2025-66076), no fix listed yet.
- 2024-01-29 — Denial of service disclosed (CVE-2023-6279), fixed in 1.4.8.
Get an email when Woostify Sites Library has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Woostify Sites Library (woostify-sites-library) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Denial of service (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woostify-sites-library (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woostify-sites-library"><img src="https://laskyr.com/plugins/woostify-sites-library/badge.svg" alt="Woostify Sites Library vulnerability status"></a>