Skip to content
Laskyr

Plugins · woosquare · data as of 2026-11-04

Is WC Shop Sync safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.7.6)

As of 2026-11-04. 9 issues are on record for older versions; version 4.7.6 or newer fixes all of them that state a fix.

Latest version
4.7.6
Last updated
2026-09-24
Active installs
1,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Want to add Square Payment Gateway for WooCommerce? Download WC Shop Sync plugin to add Square payments, inventory sync, customer data, orders, etc. — by Saad Iqbal

What to do

  1. Update to the latest version (4.7.6). Anything older than 4.7.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woosquare --field=version shows what you run; wp plugin update woosquare updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-119466 · published 2026-10-30

Cross-site request forgery (CSRF) in WC Shop Sync (4.7.5 and older)

Affected
4.7.5 and older
Fixed in
4.7.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in WPExperts APIExperts Square for WooCommerce woosquare allows Cross Site Request Forgery.This issue affects APIExperts Square for WooCommerce: from n/a through 4.7.5.

NVD CVE-2026-119466Patchstack advisory

medium 5.3 CVE-2026-115959 · published 2026-10-26

Missing authorization check in WC Shop Sync (4.7.5 and older)

Affected
4.7.5 and older
Fixed in
4.7.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WPExperts APIExperts Square for WooCommerce woosquare allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects APIExperts Square for WooCommerce: from n/a through 4.7.5.

NVD CVE-2026-115959Patchstack advisory

medium 4.3 CVE-2026-115960 · published 2026-10-26

Missing authorization check in WC Shop Sync (4.7.5 and older)

Affected
4.7.5 and older
Fixed in
4.7.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WPExperts APIExperts Square for WooCommerce woosquare allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects APIExperts Square for WooCommerce: from n/a through 4.7.5.

NVD CVE-2026-115960Patchstack advisory

medium 5.3 CVE-2026-110367 · published 2026-10-15

Missing authorization check in WC Shop Sync (4.7.5 and older)

Affected
4.7.5 and older
Fixed in
4.7.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WPExperts APIExperts Square for WooCommerce woosquare allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects APIExperts Square for WooCommerce: from n/a through 4.7.5.

NVD CVE-2026-110367Patchstack advisory

high 8.5 CVE-2026-57810 · published 2026-07-13

SQL injection in WC Shop Sync (4.7.4 and older)

Affected
4.7.4 and older
Fixed in
4.7.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Saad Iqbal APIExperts Square for WooCommerce woosquare allows Blind SQL Injection.This issue affects APIExperts Square for WooCommerce: from n/a through <= 4.7.4.

NVD CVE-2026-57810Patchstack advisory

high 8.3 CVE-2026-54848 · published 2026-06-25

Information disclosure in WC Shop Sync (4.7.3 and older)

Affected
4.7.3 and older
Fixed in
4.7.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in Saad Iqbal APIExperts Square for WooCommerce allows Retrieve Embedded Sensitive Data. This issue affects APIExperts Square for WooCommerce: from n/a through 4.7.3.

NVD CVE-2026-54848Patchstack advisory

high 8.5 CVE-2026-45211 · published 2026-05-12

SQL injection in WC Shop Sync (4.7.1 and older)

Affected
4.7.1 and older
Fixed in
4.7.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Saad Iqbal APIExperts Square for WooCommerce woosquare allows Blind SQL Injection.This issue affects APIExperts Square for WooCommerce: from n/a through <= 4.7.1.

NVD CVE-2026-45211Patchstack advisory

medium 5.3 CVE-2022-47182 · published 2024-12-13

Missing authorization check in WC Shop Sync (4.4.1 and older)

Affected
4.4.1 and older
Fixed in
4.4.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Wpexpertsio APIExperts Square for WooCommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects APIExperts Square for WooCommerce: from n/a through 4.4.1.

NVD CVE-2022-47182Patchstack advisory

medium 6.1 CVE-2024-27959 · published 2024-03-17

Reflected cross-site scripting (XSS) in WC Shop Sync (4.2.9 and older)

Affected
4.2.9 and older
Fixed in
4.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Wpexpertsio WC Shop Sync – Integrate Square and WooCommerce for Seamless Shop Management allows Reflected XSS.This issue affects WC Shop Sync – Integrate Square and WooCommerce for Seamless Shop Management: from n/a through 4.2.9.

NVD CVE-2024-27959Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WC Shop Sync vulnerability status badge
<a href="https://laskyr.com/plugins/woosquare"><img src="https://laskyr.com/plugins/woosquare/badge.svg" alt="WC Shop Sync vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit