Skip to content
Laskyr

Plugins · woocommerce-wholesale-prices · data as of 2026-11-04

Is Wholesale Suite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.1)

As of 2026-11-04. 5 issues are on record for older versions; version 2.2.7 or newer fixes all of them that state a fix.

Latest version
2.3.1
Last updated
2026-10-26
Active installs
20,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

WooCommerce wholesale plugin for serving wholesale & B2B customers. Adds wholesale pricing, user roles, dynamic pricing & more. — by Josh Kohlbach

What to do

  1. Update to the latest version (2.3.1). Anything older than 2.2.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-wholesale-prices --field=version shows what you run; wp plugin update woocommerce-wholesale-prices updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-27541 · published 2026-03-05

Privilege escalation in Wholesale Suite (2.2.6 and older)

Affected
2.2.6 and older
Fixed in
2.2.7
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in Josh Kohlbach Wholesale Suite woocommerce-wholesale-prices allows Privilege Escalation.This issue affects Wholesale Suite: from n/a through <= 2.2.6.

NVD CVE-2026-27541Patchstack advisory

high 7.2 CVE-2025-49924 · published 2025-10-22

Privilege escalation in Wholesale Suite (2.2.4.2 and older)

Affected
2.2.4.2 and older
Fixed in
2.2.5
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in Josh Kohlbach Wholesale Suite woocommerce-wholesale-prices allows Privilege Escalation.This issue affects Wholesale Suite: from n/a through <= 2.2.4.2.

NVD CVE-2025-49924Patchstack advisory

medium 5.3 CVE-2024-38745 · published 2024-11-01

Missing authorization check in Wholesale Suite (2.1.12 and older)

Affected
2.1.12 and older
Fixed in
2.2.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Rymera Web Co Wholesale Suite allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Wholesale Suite: from n/a through 2.1.12.

NVD CVE-2024-38745Patchstack advisory

high 8.8 CVE-2022-34344 · published 2024-01-08

Missing authorization check in Wholesale Suite (2.1.5 and older)

Affected
2.1.5 and older
Fixed in
2.1.5.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in Rymera Web Co Wholesale Suite – WooCommerce Wholesale Prices, B2B, Catalog Mode, Order Form, Wholesale User Roles, Dynamic Pricing & More.This issue affects Wholesale Suite – WooCommerce Wholesale Prices, B2B, Catalog Mode, Order Form, Wholesale User Roles, Dynamic Pricing & More: from n/a through 2.1.5.

NVD CVE-2022-34344Patchstack advisory

medium 5.4 CVE-2022-41640 · published 2023-05-09

Stored cross-site scripting (XSS) in Wholesale Suite (2.1.5 and older)

Affected
2.1.5 and older
Fixed in
2.1.5.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (subscriber+) Stored Cross-Site Scripting (XSS) vulnerability in Rymera Web Co Wholesale Suite plugin <= 2.1.5 versions.

NVD CVE-2022-41640Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Wholesale Suite vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-wholesale-prices"><img src="https://laskyr.com/plugins/woocommerce-wholesale-prices/badge.svg" alt="Wholesale Suite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit