Skip to content
Laskyr

Plugins · woocommerce-store-toolkit · data as of 2026-11-04

Is Store Toolkit safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.5)

As of 2026-11-04. 3 issues are on record for older versions; version 2.4.4 or newer fixes all of them that state a fix.

Latest version
2.4.5
Last updated
2026-07-06
Active installs
8,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
6.8.12

A huge set of Quick Enhancements and Handy Tools for WooCommerce – the ultimate WooCommerce booster! — by Josh Kohlbach

What to do

  1. Update to the latest version (2.4.5). Anything older than 2.4.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-store-toolkit --field=version shows what you run; wp plugin update woocommerce-store-toolkit updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2025-60204 · published 2025-11-06

File inclusion in Store Toolkit (2.4.3 and older)

Affected
2.4.3 and older
Fixed in
2.4.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Josh Kohlbach WooCommerce Store Toolkit woocommerce-store-toolkit allows PHP Local File Inclusion.This issue affects WooCommerce Store Toolkit: from n/a through <= 2.4.3.

NVD CVE-2025-60204Patchstack advisory

critical 9.8 CVE-2016-10922 · published 2019-08-22

Privilege escalation in Store Toolkit (older than 1.5.7)

Affected
older than 1.5.7
Fixed in
1.5.7
Access needed (per CVSS)
No login needed
Range from
advisory text · score by NVD
Details from the advisory

The woocommerce-store-toolkit plugin before 1.5.7 for WordPress has privilege escalation.

NVD CVE-2016-10922wordpress.org

critical 9.8 CVE-2016-10923 · published 2019-08-22

Privilege escalation in Store Toolkit (older than 1.5.8)

Affected
older than 1.5.8
Fixed in
1.5.8
Access needed (per CVSS)
No login needed
Range from
advisory text · score by NVD
Details from the advisory

The woocommerce-store-toolkit plugin before 1.5.8 for WordPress has privilege escalation.

NVD CVE-2016-10923wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Store Toolkit vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-store-toolkit"><img src="https://laskyr.com/plugins/woocommerce-store-toolkit/badge.svg" alt="Store Toolkit vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit