Skip to content
Laskyr

Plugins · woocommerce-stock-manager · data as of 2026-11-04

Is Stock Manager for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.11.0)

As of 2026-11-04. 3 issues are on record for older versions; version 3.6.0 or newer fixes all of them that state a fix.

Latest version
3.11.0
Last updated
2026-10-01
Active installs
20,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

WooCommerce stock management plugin to manage and edit product stock and their variables from a single dashboard. Stock log, import/export, filters! — by storeapps

What to do

  1. Update to the latest version (3.11.0). Anything older than 3.6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-stock-manager --field=version shows what you run; wp plugin update woocommerce-stock-manager updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-24365 · published 2026-01-22

Cross-site request forgery (CSRF) in Stock Manager for WooCommerce (3.6.0 and older)

Affected
3.6.0 and older
Fixed in
3.6.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in storeapps Stock Manager for WooCommerce woocommerce-stock-manager allows Cross Site Request Forgery.This issue affects Stock Manager for WooCommerce: from n/a through < 3.6.0.

NVD CVE-2026-24365Patchstack advisory

high 8.8 CVE-2023-35091 · published 2023-07-11

Cross-site request forgery (CSRF) in Stock Manager for WooCommerce (2.10.0 and older)

Affected
2.10.0 and older
Fixed in
2.11.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in StoreApps Stock Manager for WooCommerce plugin <= 2.10.0 versions.

NVD CVE-2023-35091Patchstack advisory

high 8.8 CVE-2021-34619 · published 2021-07-21

Cross-site request forgery (CSRF) in Stock Manager for WooCommerce (2.5.7 to 2.5.7)

Affected
2.5.7 to 2.5.7
Fixed in
2.6.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WooCommerce Stock Manager WordPress plugin is vulnerable to Cross-Site Request Forgery leading to Arbitrary File Upload in versions up to, and including, 2.5.7 due to missing nonce and file validation in the /woocommerce-stock-manager/trunk/admin/views/import-export.php file.

NVD CVE-2021-34619Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Stock Manager for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-stock-manager"><img src="https://laskyr.com/plugins/woocommerce-stock-manager/badge.svg" alt="Stock Manager for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit