Skip to content
Laskyr

Plugins · woocommerce-square · data as of 2026-11-04

Is WooCommerce Square safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.5.2)

As of 2026-11-04. 2 issues are on record for older versions; version 5.1.2 or newer fixes all of them that state a fix.

Latest version
5.5.2
Last updated
2026-10-15
Active installs
80,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Securely accept payments, synchronize sales, and seamlessly manage inventory and product data between WooCommerce and Square POS. — by WooCommerce

What to do

  1. Update to the latest version (5.5.2). Anything older than 5.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-square --field=version shows what you run; wp plugin update woocommerce-square updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2025-13457 · published 2026-01-10

Missing authorization check in WooCommerce Square (4.2.0 up to (not including) 4.2.3, 4.3.0 up to (not including) 4.3.2, 4.4.0 up to (not including) 4.4.2, 4.5.0 up to (not including) 4.5.2, 4.6.0 up to (not including) 4.6.4, 4.7.0 up to (not including) 4.7.4, 4.8.0 up to (not including) 4.8.8, 4.9.0 up to (not including) 4.9.9, 5.0.0 up to (not including) 5.0.1, 5.1.0 up to (not including) 5.1.2)

Affected
4.2.0 up to (not including) 4.2.3, 4.3.0 up to (not including) 4.3.2, 4.4.0 up to (not including) 4.4.2, 4.5.0 up to (not including) 4.5.2, 4.6.0 up to (not including) 4.6.4, 4.7.0 up to (not including) 4.7.4, 4.8.0 up to (not including) 4.8.8, 4.9.0 up to (not including) 4.9.9, 5.0.0 up to (not including) 5.0.1, 5.1.0 up to (not including) 5.1.2
Fixed in
5.1.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WooCommerce Square plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 5.1.1 via the get_token_by_id function due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to expose arbitrary Square "ccof" (credit card on file) values and leverage this value to potentially make fraudulent charges on the target site.

NVD CVE-2025-13457Wordfence advisoryCode change (fix)

high 8.1 CVE-2023-35876 · published 2023-12-20

Missing authorization check in WooCommerce Square (3.8.1 and older)

Affected
3.8.1 and older
Fixed in
3.8.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in WooCommerce WooCommerce Square.This issue affects WooCommerce Square: from n/a through 3.8.1.

NVD CVE-2023-35876Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WooCommerce Square vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-square"><img src="https://laskyr.com/plugins/woocommerce-square/badge.svg" alt="WooCommerce Square vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit