Plugins · woocommerce-sendinblue-newsletter-subscription · data as of 2026-11-04
Is Brevo for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 4.0.63
- Last updated
- 2026-10-28
- Active installs
- 30,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
All-in-one WooCommerce email marketing, automation, SMS, and CRM by Brevo. Grow your store with powerful marketing tools. — by Brevo
What to do
- Update to the latest version (4.0.63). Anything older than 4.0.50 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woocommerce-sendinblue-newsletter-subscription --field=version shows what you run; wp plugin update woocommerce-sendinblue-newsletter-subscription updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2025-14436 · published 2026-01-08
Stored cross-site scripting (XSS) in Brevo for WooCommerce (4.0.49 and older)
- Affected
- 4.0.49 and older
- Fixed in
- 4.0.50 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Brevo for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘user_connection_id’ parameter in all versions up to, and including, 4.0.49 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-14436Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2025-66128 · published 2025-12-16
Missing authorization check in Brevo for WooCommerce (4.0.49 and older)
- Affected
- 4.0.49 and older
- Fixed in
- 4.0.50
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Brevo Sendinblue for WooCommerce woocommerce-sendinblue-newsletter-subscription allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Sendinblue for WooCommerce: from n/a through <= 4.0.49.
high 8.5 CVE-2024-32807 · published 2024-05-06
Path traversal / file read in Brevo for WooCommerce (4.0.17 and older)
- Affected
- 4.0.17 and older
- Fixed in
- 4.0.18
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Brevo Sendinblue for WooCommerce allows Relative Path Traversal, Manipulating Web Input to File System Calls.This issue affects Sendinblue for WooCommerce: from n/a through 4.0.17.
Recent activity
- 2026-10-28 — latest release on wordpress.org (4.0.63).
- 2026-01-08 — Stored cross-site scripting (XSS) disclosed (CVE-2025-14436), fixed in 4.0.50.
- 2025-12-16 — Missing authorization check disclosed (CVE-2025-66128), fixed in 4.0.50.
- 2024-05-06 — Path traversal / file read disclosed (CVE-2024-32807), fixed in 4.0.18.
Get an email when Brevo for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Brevo for WooCommerce (woocommerce-sendinblue-newsletter-subscription) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Brevo (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1) · Missing authorization (1) · Path traversal and file read (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woocommerce-sendinblue-newsletter-subscription (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woocommerce-sendinblue-newsletter-subscription"><img src="https://laskyr.com/plugins/woocommerce-sendinblue-newsletter-subscription/badge.svg" alt="Brevo for WooCommerce vulnerability status"></a>