Plugins · woocommerce-products-slider · data as of 2026-11-04
Is Product Slider, Product Grid, Product Masonry safe? Known vulnerabilities and latest version
- Latest version
- 1.13.63
- Last updated
- 2026-07-14
- Active installs
- 9,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8
Fully responsive and mobile ready Carousel Slider for your woo-commerce product. unlimited slider anywhere via short-codes and easy admin setting. — by PickPlugins
What to do
- Update to the latest version (1.13.63). Anything older than 1.13.63 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woocommerce-products-slider --field=version shows what you run; wp plugin update woocommerce-products-slider updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-65456 · published 2026-07-23
Missing authorization check in Product Slider, Product Grid, Product Masonry (1.13.62 and older)
- Affected
- 1.13.62 and older
- Fixed in
- 1.13.63
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Insecure Direct Object References (IDOR) in Product Slider for WooCommerce <= 1.13.62 versions.
medium 6.5 CVE-2026-25455 · published 2026-03-25
Missing authorization check in Product Slider, Product Grid, Product Masonry (1.13.61 and older)
- Affected
- 1.13.61 and older
- Fixed in
- 1.13.62
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in PickPlugins Product Slider for WooCommerce woocommerce-products-slider allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Product Slider for WooCommerce: from n/a through <= 1.13.61.
medium 6.1 CVE-2024-45459 · published 2024-09-15
Reflected cross-site scripting (XSS) in Product Slider, Product Grid, Product Masonry (1.13.50 and older)
- Affected
- 1.13.50 and older
- Fixed in
- 1.13.51
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PickPlugins Product Slider for WooCommerce woocommerce-products-slider allows Reflected XSS.This issue affects Product Slider for WooCommerce: from n/a through <= 1.13.50.
Recent activity
- 2026-07-14 — latest release on wordpress.org (1.13.63).
- 2026-07-23 — Missing authorization check disclosed (CVE-2026-65456), fixed in 1.13.63.
- 2026-03-25 — Missing authorization check disclosed (CVE-2026-25455), fixed in 1.13.62.
- 2024-09-15 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-45459), fixed in 1.13.51.
Get an email when Product Slider, Product Grid, Product Masonry has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Product Slider, Product Grid, Product Masonry (woocommerce-products-slider) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by PickPlugins (4 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woocommerce-products-slider (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woocommerce-products-slider"><img src="https://laskyr.com/plugins/woocommerce-products-slider/badge.svg" alt="Product Slider, Product Grid, Product Masonry vulnerability status"></a>