Plugins · woocommerce-product-stock-alert · data as of 2026-11-04
Is Notifima safe? Known vulnerabilities and latest version
- Latest version
- 3.1.9
- Last updated
- 2026-11-03
- Active installs
- 2,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
WooCommerce back in stock notifier and stock manager plugin. Manage inventory, enable waitlists, and send stock notifications automatically. — by MultiVendorX
What to do
- Update to the latest version (3.1.9). Anything older than 3.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woocommerce-product-stock-alert --field=version shows what you run; wp plugin update woocommerce-product-stock-alert updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-61945 · published 2026-07-23
Information disclosure in Notifima (3.0.6 and older)
- Affected
- 3.0.6 and older
- Fixed in
- 3.1.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in MultiVendorX WooCommerce Product Stock Alert allows Retrieve Embedded Sensitive Data. This issue affects WooCommerce Product Stock Alert: from n/a through 3.0.6.
medium 6.5 CVE-2023-37971 · published 2024-12-13
Missing authorization check in Notifima (2.0.1 and older)
- Affected
- 2.0.1 and older
- Fixed in
- 2.0.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in MultiVendorX WooCommerce Product Stock Alert allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WooCommerce Product Stock Alert: from n/a through 2.0.1.
high 7.5 CVE-2023-37972 · published 2023-11-30
Information disclosure in Notifima (2.0.1 and older)
- Affected
- 2.0.1 and older
- Fixed in
- 2.0.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in MultiVendorX Product Stock Manager & Notifier for WooCommerce.This issue affects Product Stock Manager & Notifier for WooCommerce: from n/a through 2.0.1.
Recent activity
- 2026-11-03 — latest release on wordpress.org (3.1.9).
- 2026-07-23 — Information disclosure disclosed (CVE-2026-61945), fixed in 3.1.0.
- 2024-12-13 — Missing authorization check disclosed (CVE-2023-37971), fixed in 2.0.2.
- 2023-11-30 — Information disclosure disclosed (CVE-2023-37972), fixed in 2.0.2.
Get an email when Notifima has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Notifima (woocommerce-product-stock-alert) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by MultiVendorX (3 tracked)
Types found in this plugin: Sensitive data exposure (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woocommerce-product-stock-alert (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woocommerce-product-stock-alert"><img src="https://laskyr.com/plugins/woocommerce-product-stock-alert/badge.svg" alt="Notifima vulnerability status"></a>