Skip to content
Laskyr

Plugins · woocommerce-paypal-payments · data as of 2026-11-01

Is WooCommerce PayPal Payments safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.2.0)

As of 2026-11-01. 3 issues are on record for older versions; version 4.0.2 or newer fixes all of them that state a fix.

Latest version
4.2.0
Last updated
2026-10-21
Active installs
800,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

PayPal's latest payment processing solution. Accept PayPal, Pay Later, credit/debit cards, alternative digital wallets and bank accounts. — by WooCommerce

What to do

  1. Update to the latest version (4.2.0). Anything older than 4.0.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-paypal-payments --field=version shows what you run; wp plugin update woocommerce-paypal-payments updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-14073 · published 2026-08-01

Missing authorization check in WooCommerce PayPal Payments (3.3.2 and older)

Affected
3.3.2 and older
Fixed in
3.4.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WooCommerce PayPal Payments plugin for WordPress is vulnerable to Sensitive Information Disclosure due to an Insecure Direct Object Reference in all versions up to, and including, 3.3.2 via the `enqueue_paypal_insights_script_on_order_received()` function due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to obtain sensitive order information including order keys, which can then be leveraged to access full customer billing details (name, email, phone, address) via the WooCommerce Store API within a 10-minute grace period after order creation.

NVD CVE-2025-14073Wordfence advisoryCode change (fix)Plugin source

high 8.2 CVE-2026-9284 · published 2026-05-23

Missing authorization check in WooCommerce PayPal Payments (4.0.1 and older)

Affected
4.0.1 and older
Fixed in
4.0.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WooCommerce PayPal Payments plugin for WordPress is vulnerable to unauthorized order manipulation and information disclosure due to missing authorization checks on the `ppc-create-order` and `ppc-get-order` WC-AJAX endpoints in all versions up to, and including, 4.0.1. The `ppc-create-order` endpoint accepts an arbitrary WooCommerce order ID in the `pay-now` context without validating order ownership, allowing attackers to create PayPal orders for any WC order and write PayPal metadata to it. The `ppc-get-order` endpoint returns full PayPal order details for any PayPal order ID without binding to the requester's session. This makes it possible for unauthenticated attackers to chain these endpoints to manipulate other customers' order payment flows and exfiltrate sensitive order details (payer information, shipping data) by creating a PayPal order for a victim's WC order and then retrieving the PayPal order data.

NVD CVE-2026-9284Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2023-35917 · published 2023-06-22

Cross-site request forgery (CSRF) in WooCommerce PayPal Payments (2.0.4 and older)

Affected
2.0.4 and older
Fixed in
2.0.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in WooCommerce PayPal Payments plugin <= 2.0.4 versions.

NVD CVE-2023-35917Patchstack advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WooCommerce PayPal Payments vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-paypal-payments"><img src="https://laskyr.com/plugins/woocommerce-paypal-payments/badge.svg" alt="WooCommerce PayPal Payments vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit