Skip to content
Laskyr

Plugins · woocommerce-payments · data as of 2026-11-01

Is WooPayments safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (11.2.0)

As of 2026-11-01. 5 issues are on record for older versions; version 10.6.0 or newer fixes all of them that state a fix.

Latest version
11.2.0
Last updated
2026-10-08
Active installs
800,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Securely accept credit and debit cards on your WooCommerce store. Manage payments without leaving your WordPress dashboard. Only with WooPayments. — by WooCommerce

What to do

  1. Update to the latest version (11.2.0). Anything older than 10.6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-payments --field=version shows what you run; wp plugin update woocommerce-payments updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-1710 · published 2026-03-31

Missing authorization check in WooPayments (10.5.1 and older)

Affected
10.5.1 and older
Fixed in
10.6.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WooPayments: Integrated WooCommerce Payments plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'save_upe_appearance_ajax' function in all versions up to, and including, 10.5.1. This makes it possible for unauthenticated attackers to update plugin settings.

NVD CVE-2026-1710Wordfence advisoryCode change (fix)research.cleantalk.orgPlugin source

high 7.5 CVE-2023-51503 · published 2023-12-31

Missing authorization check in WooPayments (6.9.2 and older)

Affected
6.9.2 and older
Fixed in
6.7.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in Automattic WooPayments – Fully Integrated Solution Built and Supported by Woo.This issue affects WooPayments – Fully Integrated Solution Built and Supported by Woo: from n/a through 6.9.2.

NVD CVE-2023-51503Patchstack advisory

critical 9.8 CVE-2023-35915 · published 2023-12-20

SQL injection in WooPayments (5.9.0 and older)

Affected
5.9.0 and older
Fixed in
5.9.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Automattic WooPayments – Fully Integrated Solution Built and Supported by Woo.This issue affects WooPayments – Fully Integrated Solution Built and Supported by Woo: from n/a through 5.9.0.

NVD CVE-2023-35915Patchstack advisory

high 7.5 CVE-2023-35916 · published 2023-12-20

Missing authorization check in WooPayments (5.9.0 and older)

Affected
5.9.0 and older
Fixed in
5.9.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in Automattic WooPayments – Fully Integrated Solution Built and Supported by Woo.This issue affects WooPayments – Fully Integrated Solution Built and Supported by Woo: from n/a through 5.9.0.

NVD CVE-2023-35916Patchstack advisory

medium 5.4 CVE-2023-49828 · published 2023-12-14

Stored cross-site scripting (XSS) in WooPayments (6.4.2 and older)

Affected
6.4.2 and older
Fixed in
6.5.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Automattic WooPayments – Fully Integrated Solution Built and Supported by Woo allows Stored XSS.This issue affects WooPayments – Fully Integrated Solution Built and Supported by Woo: from n/a through 6.4.2.

NVD CVE-2023-49828Patchstack advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WooPayments vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-payments"><img src="https://laskyr.com/plugins/woocommerce-payments/badge.svg" alt="WooPayments vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit