Skip to content
Laskyr

Plugins · woocommerce-myparcel · data as of 2026-11-04

Is MyParcel safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.26.0)

As of 2026-11-04. 2 issues are on record for older versions; version 4.25.2 or newer fixes all of them that state a fix.

Latest version
4.26.0
Last updated
2026-08-11
Active installs
8,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Export your WooCommerce orders to MyParcel (www.myparcel.nl) and print labels directly from the WooCommerce admin — by Richard Perdaan

What to do

  1. Update to the latest version (4.26.0). Anything older than 4.25.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-myparcel --field=version shows what you run; wp plugin update woocommerce-myparcel updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-8678 · published 2026-07-11

Missing authorization check in MyParcel (4.25.1 and older)

Affected
4.25.1 and older
Fixed in
4.25.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MyParcel plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.25.1. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to view and modify shipment options — including carrier, delivery type, package type, number of labels, weight, signature requirement, and insurance — on any arbitrary order.

NVD CVE-2026-8678Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2024-9608 · published 2024-12-13

Reflected cross-site scripting (XSS) in MyParcel (4.24.1 and older)

Affected
4.24.1 and older
Fixed in
4.24.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MyParcel plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 4.24.1. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Please note this is only exploitable when the WooCommerce store is set to Belgium.

NVD CVE-2024-9608Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MyParcel vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-myparcel"><img src="https://laskyr.com/plugins/woocommerce-myparcel/badge.svg" alt="MyParcel vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit