Skip to content
Laskyr

Plugins · woocommerce-multilingual · data as of 2026-11-04

Is WPML Multilingual & Multicurrency for WooComme… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.6.3)

As of 2026-11-04. 8 issues are on record for older versions; version 5.6.3 or newer fixes all of them that state a fix.

Latest version
5.6.3
Last updated
2026-10-07
Active installs
100,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Make your store multilingual and enable multiple currencies. — by Amir Helzer

What to do

  1. Update to the latest version (5.6.3). Anything older than 5.6.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-multilingual --field=version shows what you run; wp plugin update woocommerce-multilingual updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2026-120563 · published 2026-11-03

SQL injection in WPML Multilingual & Multicurrency for WooComme… (5.5.7 and older)

Affected
5.5.7 and older
Fixed in
5.5.8 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WooCommerce Multilingual & Multicurrency with WPML plugin for WordPress is vulnerable to SQL Injection in all versions up to, and including, 5.5.7. This is due to insufficient input validation on the currency exchange rate parameter in the save_currency() AJAX handler, which lacks capability checks and allows subscriber-level users to store malicious SQL payloads that are later concatenated directly into ORDER BY clauses without proper sanitization. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to append additional SQL queries to extract sensitive information from the database.

NVD CVE-2026-120563Wordfence advisoryCode change (fix)Plugin source

high 7.2 CVE-2026-62130 · published 2026-10-10

PHP object injection in WPML Multilingual & Multicurrency for WooComme… (5.5.8 and older)

Affected
5.5.8 and older
Fixed in
5.6.3
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Shop manager PHP Object Injection in WooCommerce Multilingual & Multicurrency <= 5.5.8 versions.

NVD CVE-2026-62130Patchstack advisory

high 7.1 CVE-2026-66711 · published 2026-08-06

Cross-site scripting (XSS) in WPML Multilingual & Multicurrency for WooComme… (5.5.6 and older)

Affected
5.5.6 and older
Fixed in
5.5.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Cross Site Scripting (XSS) in WooCommerce Multilingual & Multicurrency <= 5.5.6 versions.

NVD CVE-2026-66711Patchstack advisory

medium 5.3 CVE-2025-26888 · published 2025-04-09

Missing authorization check in WPML Multilingual & Multicurrency for WooComme… (5.3.8 and older)

Affected
5.3.8 and older
Fixed in
5.3.9
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Amir Helzer WooCommerce Multilingual & Multicurrency woocommerce-multilingual allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WooCommerce Multilingual & Multicurrency: from n/a through <= 5.3.8.

NVD CVE-2025-26888Patchstack advisory

high 8.8 CVE-2024-44006 · published 2024-11-01

Missing authorization check in WPML Multilingual & Multicurrency for WooComme… (5.3.6 and older)

Affected
5.3.6 and older
Fixed in
5.3.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in Amir Helzer WooCommerce Multilingual & Multicurrency woocommerce-multilingual.This issue affects WooCommerce Multilingual & Multicurrency: from n/a through <= 5.3.6.

NVD CVE-2024-44006Patchstack advisory

medium 6.1 CVE-2024-8629 · published 2024-10-08

Reflected cross-site scripting (XSS) in WPML Multilingual & Multicurrency for WooComme… (5.3.7 and older)

Affected
5.3.7 and older
Fixed in
5.3.8 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WooCommerce Multilingual & Multicurrency with WPML plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 5.3.7. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-8629Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2024-30466 · published 2024-06-09

Missing authorization check in WPML Multilingual & Multicurrency for WooComme… (5.3.4 and older)

Affected
5.3.4 and older
Fixed in
5.3.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in OnTheGoSystems WooCommerce Multilingual & Multicurrency.This issue affects WooCommerce Multilingual & Multicurrency: from n/a through 5.3.4.

NVD CVE-2024-30466Patchstack advisory

high 7.2 CVE-2024-32602 · published 2024-04-18

SQL injection in WPML Multilingual & Multicurrency for WooComme… (5.3.3.1 and older)

Affected
5.3.3.1 and older
Fixed in
5.3.4
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in OnTheGoSystems WooCommerce Multilingual & Multicurrency.This issue affects WooCommerce Multilingual & Multicurrency: from n/a through 5.3.3.1.

NVD CVE-2024-32602Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPML Multilingual & Multicurrency for WooComme… vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-multilingual"><img src="https://laskyr.com/plugins/woocommerce-multilingual/badge.svg" alt="WPML Multilingual & Multicurrency for WooComme… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit