Skip to content
Laskyr

Plugins · woocommerce-legacy-rest-api · data as of 2026-11-01

Is WooCommerce Legacy REST API safe? Known vulnerabilities and latest version

No known vulnerabilities on record for WooCommerce Legacy REST API

As of 2026-11-01, none of the sources we check list a vulnerability for this plugin. That is not proof it has none; keep it updated.

Latest version
1.0.6
Last updated
2026-10-14
Active installs
400,000+
Known issues on record
0
Unpatched in latest
0
Tested up to WP
— · PHP 7.4+

The WooCommerce Legacy REST API, which is now part of WooCommerce itself but will be removed in WooCommerce 9.0. — by Automattic

What to do

  1. Update to the latest version (1.0.6). Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-legacy-rest-api --field=version shows what you run; wp plugin update woocommerce-legacy-rest-api updates it.

Known vulnerabilities

None on record in the sources we check, as of 2026-11-01.

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WooCommerce Legacy REST API vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-legacy-rest-api"><img src="https://laskyr.com/plugins/woocommerce-legacy-rest-api/badge.svg" alt="WooCommerce Legacy REST API vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit