Skip to content
Laskyr

Plugins · woocommerce-gateway-stripe · data as of 2026-11-01

Is WooCommerce Stripe Payment Gateway safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (11.1.1)

As of 2026-11-01. 5 issues are on record for older versions; version 10.7.1 or newer fixes all of them that state a fix.

Latest version
11.1.1
Last updated
2026-10-16
Active installs
700,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Accept debit and credit cards in 135+ currencies, many local methods like Alipay, ACH, and SEPA, and express checkout with Apple Pay and Google Pay. — by WooCommerce

What to do

  1. Update to the latest version (11.1.1). Anything older than 10.7.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-gateway-stripe --field=version shows what you run; wp plugin update woocommerce-gateway-stripe updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-2381 · published 2026-06-16

Missing authorization check in WooCommerce Stripe Payment Gateway (10.7.0 and older)

Affected
10.7.0 and older
Fixed in
10.7.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WooCommerce Stripe Payment Gateway plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the `ajax_pay_for_order()` function in all versions up to, and including, 10.7.0 This is due to a missing order ownership or order_key verification when processing payment for an order via the `wc_stripe_pay_for_order` WC-AJAX endpoint. The function only validates a nonce (which is publicly available on any WooCommerce page where Express Checkout is enabled), but does not verify that the requesting user owns the target order and is allowed to modify it. This makes it possible for unauthenticated attackers to force any pending order into a failed status by providing a fake payment method, causing a payment exception that updates the order status to "failed" via sequential order ID enumeration.

NVD CVE-2026-2381Wordfence advisoryCode change (fix)research.cleantalk.orgPlugin source

critical 9.8 CVE-2023-35049 · published 2024-06-19

Missing authorization check in WooCommerce Stripe Payment Gateway (7.4.0 and older)

Affected
7.4.0 and older
Fixed in
7.4.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in WooCommerce WooCommerce Stripe Payment Gateway.This issue affects WooCommerce Stripe Payment Gateway: from n/a through 7.4.0.

NVD CVE-2023-35049Patchstack advisory

high 8.8 CVE-2023-44999 · published 2024-03-27

Cross-site request forgery (CSRF) in WooCommerce Stripe Payment Gateway (7.6.0 and older)

Affected
7.6.0 and older
Fixed in
7.6.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in WooCommerce WooCommerce Stripe Payment Gateway.This issue affects WooCommerce Stripe Payment Gateway: from n/a through 7.6.0.

NVD CVE-2023-44999Patchstack advisory

critical 9.8 CVE-2023-51502 · published 2024-01-05

Missing authorization check in WooCommerce Stripe Payment Gateway (7.6.1 and older)

Affected
7.6.1 and older
Fixed in
7.6.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in WooCommerce WooCommerce Stripe Payment Gateway.This issue affects WooCommerce Stripe Payment Gateway: from n/a through 7.6.1.

NVD CVE-2023-51502Patchstack advisory

high 7.5 CVE-2023-34000 · published 2023-06-14

Missing authorization check in WooCommerce Stripe Payment Gateway (7.4.0 and older)

Affected
7.4.0 and older
Fixed in
7.4.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. IDOR vulnerability leading to PII Disclosure in WooCommerce Stripe Payment Gateway plugin <= 7.4.0 versions.

NVD CVE-2023-34000Patchstack advisoryPatchstack advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WooCommerce Stripe Payment Gateway vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-gateway-stripe"><img src="https://laskyr.com/plugins/woocommerce-gateway-stripe/badge.svg" alt="WooCommerce Stripe Payment Gateway vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit