Plugins · woocommerce-for-paygent-payment-main · data as of 2026-11-04
Is PAYGENT for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 3.0.1
- Last updated
- 2026-10-23
- Active installs
- 100+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
PAYGENT Payment Gateway plugin provides all popular online payment methods for your Woocommerce webshop in Japan. — by shohei.tanaka
What to do
- Update to the latest version (3.0.1). Anything older than 2.4.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woocommerce-for-paygent-payment-main --field=version shows what you run; wp plugin update woocommerce-for-paygent-payment-main updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2025-14078 · published 2026-01-17
Missing authorization check in PAYGENT for WooCommerce (2.4.6 and older)
- Affected
- 2.4.6 and older
- Fixed in
- 2.4.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The PAYGENT for WooCommerce plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 2.4.6. This is due to missing authorization checks on the paygent_check_webhook function combined with the paygent_permission_callback function unconditionally returning true on line 199. This makes it possible for unauthenticated attackers to manipulate payment callbacks and modify order statuses by sending forged payment notifications via the `/wp-json/paygent/v1/check/` endpoint.
NVD CVE-2025-14078Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-23 — latest release on wordpress.org (3.0.1).
- 2026-01-17 — Missing authorization check disclosed (CVE-2025-14078), fixed in 2.4.7.
Get an email when PAYGENT for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PAYGENT for WooCommerce (woocommerce-for-paygent-payment-main) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by shohei.tanaka (2 tracked)
Types found in this plugin: Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woocommerce-for-paygent-payment-main (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woocommerce-for-paygent-payment-main"><img src="https://laskyr.com/plugins/woocommerce-for-paygent-payment-main/badge.svg" alt="PAYGENT for WooCommerce vulnerability status"></a>