Plugins · woocommerce-for-japan · data as of 2026-11-04
Is Japanized for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 3.0.1
- Last updated
- 2026-10-31
- Active installs
- 10,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.3+
Essential Japanese localization toolkit for WooCommerce - adds address formats, payment methods, delivery scheduling, and legal compliance. — by shohei.tanaka
What to do
- Update to the latest version (3.0.1). Anything older than 2.9.13 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woocommerce-for-japan --field=version shows what you run; wp plugin update woocommerce-for-japan updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-57340 · published 2026-06-29
Missing authorization check in Japanized for WooCommerce (2.9.12 and older)
- Affected
- 2.9.12 and older
- Fixed in
- 2.9.13
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in Japanized For WooCommerce <= 2.9.12 versions.
medium 5.3 CVE-2026-1305 · published 2026-02-27
Authentication bypass in Japanized for WooCommerce (2.8.4 and older)
- Affected
- 2.8.4 and older
- Fixed in
- 2.8.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Japanized for WooCommerce plugin for WordPress is vulnerable to Improper Authentication in versions up to, and including, 2.8.4. This is due to a flawed permission check in the `paidy_webhook_permission_check` function that unconditionally returns `true` when the webhook signature header is omitted. This makes it possible for unauthenticated attackers to bypass payment verification and fraudulently mark orders as "Processing" or "Completed" without actual payment via a crafted POST request to the Paidy webhook endpoint.
NVD CVE-2026-1305Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2025-14886 · published 2026-01-09
Missing authorization check in Japanized for WooCommerce (2.7.17 and older)
- Affected
- 2.7.17 and older
- Fixed in
- 2.8.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Japanized for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the `order` REST API endpoint in all versions up to, and including, 2.7.17. This makes it possible for unauthenticated attackers to mark any WooCommerce order as processed/completed.
medium 5.4 CVE-2025-48284 · published 2025-05-19
Cross-site request forgery (CSRF) in Japanized for WooCommerce (2.6.40 and older)
- Affected
- 2.6.40 and older
- Fixed in
- 2.6.41
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in shohei.tanaka Japanized For WooCommerce woocommerce-for-japan allows Cross Site Request Forgery.This issue affects Japanized For WooCommerce: from n/a through <= 2.6.40.
high 8.6 CVE-2023-47698 · published 2024-12-09
Missing authorization check in Japanized for WooCommerce (2.6.4 and older)
- Affected
- 2.6.4 and older
- Fixed in
- 2.6.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in shohei.tanaka Japanized For WooCommerce woocommerce-for-japan allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Japanized For WooCommerce: from n/a through <= 2.6.4.
medium 6.1 CVE-2023-0948 · published 2023-05-08
Reflected cross-site scripting (XSS) in Japanized for WooCommerce (older than 2.5.8)
- Affected
- older than 2.5.8
- Fixed in
- 2.5.8
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Japanized For WooCommerce WordPress plugin before 2.5.8 does not escape generated URLs before outputting them in attributes, leading to Reflected Cross-Site Scripting
medium 6.1 CVE-2023-0942 · published 2023-02-21
Reflected cross-site scripting (XSS) in Japanized for WooCommerce (2.5.4 and older)
- Affected
- 2.5.4 and older
- Fixed in
- 2.5.5 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Japanized For WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘tab’ parameter in versions up to, and including, 2.5.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2023-0942Wordfence advisoryCode change (fix)Wordfence advisoryPlugin source
Recent activity
- 2026-10-31 — latest release on wordpress.org (3.0.1).
- 2026-06-29 — Missing authorization check disclosed (CVE-2026-57340), fixed in 2.9.13.
- 2026-02-27 — Authentication bypass disclosed (CVE-2026-1305), fixed in 2.8.5.
- 2026-01-09 — Missing authorization check disclosed (CVE-2025-14886), fixed in 2.8.0.
Get an email when Japanized for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Japanized for WooCommerce (woocommerce-for-japan) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by shohei.tanaka (2 tracked)
Types found in this plugin: Missing authorization (3) · Cross-site scripting (XSS) (2) · Authentication bypass (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woocommerce-for-japan (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woocommerce-for-japan"><img src="https://laskyr.com/plugins/woocommerce-for-japan/badge.svg" alt="Japanized for WooCommerce vulnerability status"></a>