Plugins · woocommerce-exporter · data as of 2026-11-04
Is Store Exporter safe? Known vulnerabilities and latest version
- Latest version
- 2.8.2
- Last updated
- 2026-10-26
- Active installs
- 6,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Export WooCommerce products, orders, customers, categories, tags, subscriptions & more into formatted files like CSV, XML, Excel 2007, XLS, XLSX. — by Josh Kohlbach
What to do
- Update to the latest version (2.8.2). Anything older than 2.8.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woocommerce-exporter --field=version shows what you run; wp plugin update woocommerce-exporter updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.9 CVE-2026-16777 · published 2026-09-18
Path traversal / file read in Store Exporter (2.8.0 and older)
- Affected
- 2.8.0 and older
- Fixed in
- 2.8.1 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Store Exporter – Export WooCommerce Products, Orders, Subscriptions, Customers plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 2.8.0 via the 'filename' parameter parameter. This makes it possible for authenticated attackers, with shop manager-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.
NVD CVE-2026-16777Wordfence advisoryCode change (fix)Plugin source
high 7.5 CVE-2025-60203 · published 2025-11-06
File inclusion in Store Exporter (2.7.6 and older)
- Affected
- 2.7.6 and older
- Fixed in
- 2.7.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Josh Kohlbach Store Exporter woocommerce-exporter allows PHP Local File Inclusion.This issue affects Store Exporter: from n/a through <= 2.7.6.
high 7.1 CVE-2025-32539 · published 2025-04-11
Reflected cross-site scripting (XSS) in Store Exporter (2.7.4 and older)
- Affected
- 2.7.4 and older
- Fixed in
- 2.7.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Josh Kohlbach Store Exporter woocommerce-exporter allows Reflected XSS.This issue affects Store Exporter: from n/a through <= 2.7.4.
medium 6.1 CVE-2024-8793 · published 2024-10-01
Reflected cross-site scripting (XSS) in Store Exporter (2.7.2.1 and older)
- Affected
- 2.7.2.1 and older
- Fixed in
- 2.7.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Store Exporter for WooCommerce – Export Products, Export Orders, Export Subscriptions, and More plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 2.7.2.1. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2024-8793Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2023-46822 · published 2023-11-06
Reflected cross-site scripting (XSS) in Store Exporter (2.7.2 and older)
- Affected
- 2.7.2 and older
- Fixed in
- 2.7.2.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Unauth. Reflected Cross-Site Scripting') vulnerability in Visser Labs Store Exporter for WooCommerce – Export Products, Export Orders, Export Subscriptions, and More plugin <= 2.7.2 versions.
medium 6.1 CVE-2022-0149 · published 2022-02-07
Reflected cross-site scripting (XSS) in Store Exporter (older than 2.7.1)
- Affected
- older than 2.7.1
- Fixed in
- 2.7.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The WooCommerce Stored Exporter WordPress plugin before 2.7.1 was affected by a Reflected Cross-Site Scripting (XSS) vulnerability in the woo_ce admin page.
critical 9.8 CVE-2016-10935 · published 2019-08-27
Privilege escalation in Store Exporter (older than 1.8.4)
- Affected
- older than 1.8.4
- Fixed in
- 1.8.4
- Access needed (per CVSS)
- No login needed
- Range from
- advisory text · score by NVD
Details from the advisory
The woocommerce-exporter plugin before 1.8.4 for WordPress has privilege escalation.
Recent activity
- 2026-10-26 — latest release on wordpress.org (2.8.2).
- 2026-09-18 — Path traversal / file read disclosed (CVE-2026-16777), fixed in 2.8.1.
- 2025-11-06 — File inclusion disclosed (CVE-2025-60203), fixed in 2.7.7.
- 2025-04-11 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-32539), fixed in 2.7.5.
Get an email when Store Exporter has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Store Exporter (woocommerce-exporter) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Josh Kohlbach (5 tracked)
Types found in this plugin: Cross-site scripting (XSS) (4) · Path traversal and file read (1) · File inclusion (1) · Privilege escalation (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woocommerce-exporter (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woocommerce-exporter"><img src="https://laskyr.com/plugins/woocommerce-exporter/badge.svg" alt="Store Exporter vulnerability status"></a>