Skip to content
Laskyr

Plugins · woocommerce-eu-vat-compliance · data as of 2026-11-04

Is European VAT Compliance Assistant for WooComme… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.36.14)

As of 2026-11-04. 1 issue is on record for older versions; version 1.36.11 or newer fixes all of them that state a fix.

Latest version
1.36.14
Last updated
2026-10-03
Active installs
3,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.1+

Assists with EU/UK/Norway/Switzerland VAT compliance for WooCommerce, for the VAT regimes that began in 2015 and were extended in 2021), including the … — by David Anderson / Team Updraft

What to do

  1. Update to the latest version (1.36.14). Anything older than 1.36.11 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-eu-vat-compliance --field=version shows what you run; wp plugin update woocommerce-eu-vat-compliance updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-100316 · published 2026-10-17

Stored cross-site scripting (XSS) in European VAT Compliance Assistant for WooComme… (1.36.10 and older)

Affected
1.36.10 and older
Fixed in
1.36.11 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The European VAT Compliance Assistant for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via CF-IPCountry Header in all versions up to, and including, 1.36.10 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The malicious header value is persisted verbatim into order post-meta during a guest checkout, meaning no account or authentication is required to plant the payload.

NVD CVE-2026-100316Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
European VAT Compliance Assistant for WooComme… vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-eu-vat-compliance"><img src="https://laskyr.com/plugins/woocommerce-eu-vat-compliance/badge.svg" alt="European VAT Compliance Assistant for WooComme… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit