Skip to content
Laskyr

Plugins · woocommerce-email-inquiry-cart-options · data as of 2026-11-04

Is Email Inquiry & Cart Options for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.5.1)

As of 2026-11-04. 1 issue is on record for older versions; version 3.5.1 or newer fixes all of them that state a fix.

Latest version
3.5.1
Last updated
2026-07-09
Active installs
800+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8

Set Product Page Rules, Hide Add to Cart, Hide Price, Show Email Inquiry, Filter Rules by Roles for logged in users. 100% Mobile responsive Email Inqu … — by Steve Truman

What to do

  1. Update to the latest version (3.5.1). Anything older than 3.5.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-email-inquiry-cart-options --field=version shows what you run; wp plugin update woocommerce-email-inquiry-cart-options updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-24526 · published 2026-01-23

Cross-site scripting (XSS) in Email Inquiry & Cart Options for WooCommerce (3.5.0 and older)

Affected
3.5.0 and older
Fixed in
3.5.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Steve Truman Email Inquiry & Cart Options for WooCommerce woocommerce-email-inquiry-cart-options allows DOM-Based XSS.This issue affects Email Inquiry & Cart Options for WooCommerce: from n/a through <= 3.5.0.

NVD CVE-2026-24526Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Email Inquiry & Cart Options for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-email-inquiry-cart-options"><img src="https://laskyr.com/plugins/woocommerce-email-inquiry-cart-options/badge.svg" alt="Email Inquiry & Cart Options for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit