Skip to content
Laskyr

Plugins · woocommerce-ajax-filters · data as of 2026-11-04

Is Advanced AJAX Product Filters safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.3)

As of 2026-11-04. 5 issues are on record for older versions; version 3.2.1 or newer fixes all of them that state a fix.

Latest version
3.3
Last updated
2026-09-07
Active installs
50,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Fast and flexible AJAX product filters for WooCommerce. Filter by categories, attributes, price, tags, rating, and more. No page reloads. — by BeRocket

What to do

  1. Update to the latest version (3.3). Anything older than 3.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-ajax-filters --field=version shows what you run; wp plugin update woocommerce-ajax-filters updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-66439 · published 2026-08-06

Cross-site scripting (XSS) in Advanced AJAX Product Filters (3.2.0.3 and older)

Affected
3.2.0.3 and older
Fixed in
3.2.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Advanced AJAX Product Filters <= 3.2.0.3 versions.

NVD CVE-2026-66439Patchstack advisory

medium 5.4 CVE-2022-45813 · published 2026-06-11

Missing authorization check in Advanced AJAX Product Filters (1.6.3.3 and older)

Affected
1.6.3.3 and older
Fixed in
1.6.3.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in BeRocket Advanced AJAX Product Filters allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects Advanced AJAX Product Filters: from n/a through 1.6.3.3.

NVD CVE-2022-45813Patchstack advisory

high 8.8 CVE-2026-1426 · published 2026-02-18

PHP object injection in Advanced AJAX Product Filters (3.1.9.6 and older)

Affected
3.1.9.6 and older
Fixed in
3.1.9.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Advanced AJAX Product Filters plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.1.9.6 via deserialization of untrusted input in the shortcode_check function within the Live Composer compatibility layer. This makes it possible for authenticated attackers, with Author-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present. Note: This vulnerability requires the Live Composer plugin to also be installed and active.

NVD CVE-2026-1426Wordfence advisoryCode change (fix)cwe.mitre.orgPlugin source

medium 6.1 CVE-2025-1505 · published 2025-02-28

Reflected cross-site scripting (XSS) in Advanced AJAX Product Filters (1.6.8.1 and older)

Affected
1.6.8.1 and older
Fixed in
1.6.8.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Advanced AJAX Product Filters plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'nonce' parameter in all versions up to, and including, 1.6.8.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2025-1505Wordfence advisoryCode change (fix)

medium 6.1 CVE-2021-24432 · published 2024-01-16

Reflected cross-site scripting (XSS) in Advanced AJAX Product Filters (older than 1.5.4.7)

Affected
older than 1.5.4.7
Fixed in
1.5.4.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Advanced AJAX Product Filters WordPress plugin does not sanitise the 'term_id' POST parameter before outputting it in the page, leading to reflected Cross-Site Scripting issue.

NVD CVE-2021-24432WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Advanced AJAX Product Filters vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-ajax-filters"><img src="https://laskyr.com/plugins/woocommerce-ajax-filters/badge.svg" alt="Advanced AJAX Product Filters vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit