Skip to content
Laskyr

Plugins · woocommerce-abandoned-cart · data as of 2026-11-04

Is Abandoned Cart Lite for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.9.0)

As of 2026-11-04. 8 issues are on record for older versions; version 6.8.2 or newer fixes all of them that state a fix.

Latest version
6.9.0
Last updated
2026-10-23
Active installs
20,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.3+

Track abandoned carts and send automated, customizable abandoned cart recovery emails. Reduce cart abandonment, recover lost revenue & increase sales. — by tychesoftwares

What to do

  1. Update to the latest version (6.9.0). Anything older than 6.8.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-abandoned-cart --field=version shows what you run; wp plugin update woocommerce-abandoned-cart updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2026-65557 · published 2026-07-27

Cross-site scripting (XSS) in Abandoned Cart Lite for WooCommerce (6.8.0 and older)

Affected
6.8.0 and older
Fixed in
6.8.1
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Shop manager Cross Site Scripting (XSS) in Abandoned Cart Lite for WooCommerce <= 6.8.0 versions.

NVD CVE-2026-65557Patchstack advisory

high 8.1 CVE-2026-12585 · published 2026-07-16

Authentication bypass in Abandoned Cart Lite for WooCommerce (older than 6.8.2)

Affected
older than 6.8.2
Fixed in
6.8.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Abandoned Cart Lite for WooCommerce WordPress plugin before 6.8.2 does not protect the integrity of its cart-recovery tokens or bind them to the requesting account, allowing unauthenticated attackers to forge a recovery link that logs them in as another user when the automatic-login option is enabled.

NVD CVE-2026-12585WPScan advisory

medium 4.3 CVE-2026-57637 · published 2026-06-26

Cross-site request forgery (CSRF) in Abandoned Cart Lite for WooCommerce (6.8.0 and older)

Affected
6.8.0 and older
Fixed in
6.8.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Request Forgery (CSRF) in Abandoned Cart Lite for WooCommerce <= 6.8.0 versions.

NVD CVE-2026-57637Patchstack advisory

medium 5.4 CVE-2023-41671 · published 2024-12-13

Missing authorization check in Abandoned Cart Lite for WooCommerce (5.16.1 and older)

Affected
5.16.1 and older
Fixed in
5.16.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in tychesoftwares Abandoned Cart Lite for WooCommerce woocommerce-abandoned-cart allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Abandoned Cart Lite for WooCommerce: from n/a through <= 5.16.1.

NVD CVE-2023-41671Patchstack advisory

medium 4.8 CVE-2023-44986 · published 2023-10-16

Stored cross-site scripting (XSS) in Abandoned Cart Lite for WooCommerce (5.15.2 and older)

Affected
5.15.2 and older
Fixed in
5.16.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Tyche Softwares Abandoned Cart Lite for WooCommerce plugin <= 5.15.2 versions.

NVD CVE-2023-44986Patchstack advisory

medium 4.3 CVE-2021-4414 · published 2023-07-12

Cross-site request forgery (CSRF) in Abandoned Cart Lite for WooCommerce (5.8.5 and older)

Affected
5.8.5 and older
Fixed in
5.8.6 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Abandoned Cart Lite for WooCommerce plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 5.8.5. This is due to missing or incorrect nonce validation on the wcal_preview_emails() function. This makes it possible for unauthenticated attackers to generate email preview templates via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2021-4414Wordfence advisoryCode change (fix)blog.nintechnet.comblog.nintechnet.comblog.nintechnet.comblog.nintechnet.com

medium 6.1 CVE-2019-25152 · published 2023-06-22

Stored cross-site scripting (XSS) in Abandoned Cart Lite for WooCommerce (older than 5.2.0)

Affected
older than 5.2.0
Fixed in
5.2.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Abandoned Cart Lite for WooCommerce and Abandoned Cart Pro for WooCommerce plugins for WordPress are vulnerable to Stored Cross-Site Scripting via multiple parameters in versions up to, and including, 5.1.3 and 7.12.0 respectively, due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in user input that will execute on the admin dashboard.

NVD CVE-2019-25152Wordfence advisoryWPScan advisoryCode change (fix)Wordfence advisory

critical 9.8 CVE-2023-2986 · published 2023-06-08

Authentication bypass in Abandoned Cart Lite for WooCommerce (5.15.1 and older)

Affected
5.15.1 and older
Fixed in
5.15.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Abandoned Cart Lite for WooCommerce plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 5.14.2. This is due to insufficient encryption on the user being supplied during the abandoned cart link decode through the plugin. This allows unauthenticated attackers to log in as users who have abandoned the cart, who are typically customers. Further security hardening was introduced in version 5.15.1 that ensures sites are no longer vulnerable through historical check-out links, and additional hardening was introduced in version 5.15.2 that ensured null key values wouldn't permit the authentication bypass.

NVD CVE-2023-2986Wordfence advisoryCode change (fix)github.comgithub.comWordfence advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Abandoned Cart Lite for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-abandoned-cart"><img src="https://laskyr.com/plugins/woocommerce-abandoned-cart/badge.svg" alt="Abandoned Cart Lite for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit