Skip to content
Laskyr

Plugins · woo-xendit-virtual-accounts · data as of 2026-11-04

Is Xendit Payment safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (8.0.0)

As of 2026-11-04. 2 issues are on record for older versions; version 7.2.0 or newer fixes all of them that state a fix.

Latest version
8.0.0
Last updated
2026-09-14
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11

Xendit Payment Gateway for WooCommerce — by Xendit

What to do

  1. Update to the latest version (8.0.0). Anything older than 7.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-xendit-virtual-accounts --field=version shows what you run; wp plugin update woo-xendit-virtual-accounts updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-66473 · published 2026-07-27

Missing authorization check in Xendit Payment (7.1.0 and older)

Affected
7.1.0 and older
Fixed in
7.2.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Xendit Payment <= 7.1.0 versions.

NVD CVE-2026-66473Patchstack advisory

medium 5.3 CVE-2025-14461 · published 2026-02-04

Missing authorization check in Xendit Payment (6.0.2 and older)

Affected
6.0.2 and older
Fixed in
6.1.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Xendit Payment plugin for WordPress is vulnerable to unauthorized order status manipulation in all versions up to, and including, 6.0.2. This is due to the plugin exposing a publicly accessible WooCommerce API callback endpoint (`wc_xendit_callback`) that processes payment callbacks without any authentication or cryptographic verification that the requests originate from Xendit's payment gateway. This makes it possible for unauthenticated attackers to mark any WooCommerce order as paid by sending a crafted POST request to the callback URL with a JSON body containing an `external_id` matching the order ID pattern and a `status` of 'PAID' or 'SETTLED', granted they can enumerate order IDs (which are sequential integers). This leads to orders being fraudulently marked as completed without any actual payment, resulting in financial loss and inventory depletion.

NVD CVE-2025-14461Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Xendit Payment vulnerability status badge
<a href="https://laskyr.com/plugins/woo-xendit-virtual-accounts"><img src="https://laskyr.com/plugins/woo-xendit-virtual-accounts/badge.svg" alt="Xendit Payment vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit