Plugins · woo-vipps · data as of 2026-11-04
Is Pay with Vipps and MobilePay for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 6.4.0
- Last updated
- 2026-11-03
- Active installs
- 5,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
Official Vipps MobilePay payment plugin for WooCommerce. — by WP Hosting AS
What to do
- Update to the latest version (6.4.0). Anything older than 6.2.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woo-vipps --field=version shows what you run; wp plugin update woo-vipps updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-94568 · published 2026-10-09
PHP object injection in Pay with Vipps and MobilePay for WooCommerce (6.2.0 and older)
- Affected
- 6.2.0 and older
- Fixed in
- 6.2.1
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in WP Hosting AS Pay with Vipps for WooCommerce woo-vipps allows Object Injection.This issue affects Pay with Vipps for WooCommerce: from n/a through 6.2.0.
medium 5.3 CVE-2026-97259 · published 2026-09-30
Missing authorization check in Pay with Vipps and MobilePay for WooCommerce (6.2.4 and older)
- Affected
- 6.2.4 and older
- Fixed in
- 6.2.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Authorization Bypass Through User-Controlled Key vulnerability in WP Hosting AS Pay with Vipps for WooCommerce allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects Pay with Vipps for WooCommerce: from n/a through 6.2.4.
medium 5.4 CVE-2023-51485 · published 2024-02-10
Stored cross-site scripting (XSS) in Pay with Vipps and MobilePay for WooCommerce (1.14.13 and older)
- Affected
- 1.14.13 and older
- Fixed in
- 1.14.14
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Hosting Pay with Vipps and MobilePay for WooCommerce allows Stored XSS.This issue affects Pay with Vipps and MobilePay for WooCommerce: from n/a through 1.14.13.
Recent activity
- 2026-11-03 — latest release on wordpress.org (6.4.0).
- 2026-10-09 — PHP object injection disclosed (CVE-2026-94568), fixed in 6.2.1.
- 2026-09-30 — Missing authorization check disclosed (CVE-2026-97259), fixed in 6.2.5.
- 2024-02-10 — Stored cross-site scripting (XSS) disclosed (CVE-2023-51485), fixed in 1.14.14.
Get an email when Pay with Vipps and MobilePay for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Pay with Vipps and MobilePay for WooCommerce (woo-vipps) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: PHP object injection (1) · Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woo-vipps (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woo-vipps"><img src="https://laskyr.com/plugins/woo-vipps/badge.svg" alt="Pay with Vipps and MobilePay for WooCommerce vulnerability status"></a>