Plugins · woo-thank-you-page-nextmove-lite · data as of 2026-11-04
Is NextMove Lite safe? Known vulnerabilities and latest version
- Latest version
- 2.24.0
- Last updated
- 2026-03-14
- Active installs
- 10,000+
- Known issues on record
- 8
- Unpatched in latest
- 1
- Tested up to WP
- 6.9.11 · PHP 7.4+
The only plugin in WooCommerce that empowers you to build profit-pulling Thank You Pages with plug & play components. — by XLPlugins
What to do
- There is no fixed version yet. If you can live without NextMove Lite for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get woo-thank-you-page-nextmove-lite --field=version shows what you run; wp plugin update woo-thank-you-page-nextmove-lite updates it.
Check your version
Known vulnerabilities
8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-0703 · published 2026-05-02
Stored cross-site scripting (XSS) in NextMove Lite (2.23.0 and older)
- Affected
- 2.23.0 and older
- Fixed in
- 2.24.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The NextMove Lite – Thank You Page for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'xlwcty_current_date' shortcode in all versions up to, and including, 2.23.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-0703Wordfence advisoryCode change (fix)Plugin source
high 7.5 CVE-2025-68048 · published 2026-02-20
Missing authorization check in NextMove Lite (2.23.0 and older)
- Affected
- 2.23.0 and older
- Fixed in
- 2.24.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in XLPlugins NextMove Lite woo-thank-you-page-nextmove-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects NextMove Lite: from n/a through <= 2.23.0.
medium 5.3 CVE-2026-24599 · published 2026-01-23
Missing authorization check in NextMove Lite (2.23.0 and older)
- Affected
- 2.23.0 and older
- Fixed in
- 2.24.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Authorization Bypass Through User-Controlled Key vulnerability in XLPlugins NextMove Lite woo-thank-you-page-nextmove-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects NextMove Lite: from n/a through <= 2.23.0.
medium 6.5 CVE-2025-62969 · published 2025-10-27
Stored cross-site scripting (XSS) in NextMove Lite (2.23.0 and older)
- Affected
- 2.23.0 and older
- Fixed in
- 2.24.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in XLPlugins NextMove Lite woo-thank-you-page-nextmove-lite allows Stored XSS.This issue affects NextMove Lite: from n/a through <= 2.23.0.
high 7.1 affects latest 2.24.0 CVE-2025-52735 · published 2025-10-22
Reflected cross-site scripting (XSS) in NextMove Lite (2.24.0 and older)
- Affected
- 2.24.0 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in XLPlugins NextMove Lite woo-thank-you-page-nextmove-lite allows Reflected XSS.This issue affects NextMove Lite: from n/a through <= 2.24.0.
medium 4.3 CVE-2024-10860 · published 2025-02-28
Missing authorization check in NextMove Lite (2.19.0 and older)
- Affected
- 2.19.0 and older
- Fixed in
- 2.20.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The NextMove Lite – Thank You Page for WooCommerce plugin for WordPress is vulnerable to unauthorized submission of data due to a missing capability check on the _submit_uninstall_reason_action() function in all versions up to, and including, 2.19.0. This makes it possible for authenticated attackers, with Subscriber-level access and above, to submit a deactivation reason on behalf of a site.
high 8.8 CVE-2024-25092 · published 2024-06-09
Missing authorization check in NextMove Lite (2.17.0 and older)
- Affected
- 2.17.0 and older
- Fixed in
- 2.18.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Missing Authorization vulnerability in XLPlugins NextMove Lite.This issue affects NextMove Lite: from n/a through 2.17.0.
medium 4.3 CVE-2024-32104 · published 2024-04-15
Cross-site request forgery (CSRF) in NextMove Lite (2.18.1 and older)
- Affected
- 2.18.1 and older
- Fixed in
- 2.18.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in XLPlugins NextMove Lite.This issue affects NextMove Lite: from n/a through 2.18.1.
Recent activity
- 2026-03-14 — latest release on wordpress.org (2.24.0).
- 2026-05-02 — Stored cross-site scripting (XSS) disclosed (CVE-2026-0703), fixed in 2.24.0.
- 2026-02-20 — Missing authorization check disclosed (CVE-2025-68048), fixed in 2.24.0.
- 2026-01-23 — Missing authorization check disclosed (CVE-2026-24599), fixed in 2.24.0.
Get an email when NextMove Lite has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for NextMove Lite (woo-thank-you-page-nextmove-lite) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (4) · Cross-site scripting (XSS) (3) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woo-thank-you-page-nextmove-lite (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woo-thank-you-page-nextmove-lite"><img src="https://laskyr.com/plugins/woo-thank-you-page-nextmove-lite/badge.svg" alt="NextMove Lite vulnerability status"></a>