Plugins · woo-stripe-payment · data as of 2026-11-04
Is Payment Plugins for Stripe WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 4.0.19
- Last updated
- 2026-10-22
- Active installs
- 100,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Accept Credit Cards, Google Pay, ApplePay, Afterpay, Affirm, ACH, Klarna, iDEAL and more all in one plugin for free! — by Payment Plugins
What to do
- Update to the latest version (4.0.19). Anything older than 4.0.18 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woo-stripe-payment --field=version shows what you run; wp plugin update woo-stripe-payment updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2026-89100 · published 2026-10-10
Reflected cross-site scripting (XSS) in Payment Plugins for Stripe WooCommerce (4.0.17 and older)
- Affected
- 4.0.17 and older
- Fixed in
- 4.0.18 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Payment Plugins for Stripe WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via '#response' URL Fragment in all versions up to, and including, 4.0.17 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that the 'Generic Errors' setting is unchecked, causing getErrorMessage() to return the raw Stripe error string unchanged rather than substituting a mapped safe message.
NVD CVE-2026-89100Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2026-80339 · published 2026-09-09
Information disclosure in Payment Plugins for Stripe WooCommerce (4.0.0 up to (not including) 4.0.12)
- Affected
- 4.0.0 up to (not including) 4.0.12
- Fixed in
- 4.0.12
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Payment Plugins for Stripe WooCommerce WordPress plugin before 4.0.12 does not validate the order key before adding order data to the JavaScript configuration it outputs on the front end, allowing unauthenticated users to obtain the billing details of any order, together with the secret that gates access to it, by iterating sequential order identifiers.
high 7.5 CVE-2026-59530 · published 2026-07-27
Missing authorization check in Payment Plugins for Stripe WooCommerce (4.0.7 and older)
- Affected
- 4.0.7 and older
- Fixed in
- 4.0.8
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in Stripe For WooCommerce <= 4.0.7 versions.
medium 5.3 CVE-2026-12654 · published 2026-07-24
Missing authorization check in Payment Plugins for Stripe WooCommerce (4.0.7 and older)
- Affected
- 4.0.7 and older
- Fixed in
- 4.0.8 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Payment Plugins for Stripe WooCommerce plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.0.7. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to mark arbitrary pending asynchronous WooCommerce orders as paid by forging a charge.pending event with attacker-controlled metadata.order_id, metadata.gateway_id, and a charge object carrying status=succeeded and captured=true, triggering payment_complete() and downstream fulfillment flows with an attacker-supplied transaction ID. Exploitation requires the merchant to have left the webhook_secret_test or webhook_secret_live option blank, which is the plugin's default state until a Stripe-issued whsec_ value is manually configured; once a non-empty secret is set, the signature verification cannot be bypassed.
NVD CVE-2026-12654Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2021-39347 · published 2021-10-04
Missing authorization check in Payment Plugins for Stripe WooCommerce (3.0.0 to 3.3.9)
- Affected
- 3.0.0 to 3.3.9
- Fixed in
- 3.3.10 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- advisory text · score by Wordfence
Details from the advisory
The Stripe for WooCommerce WordPress plugin is missing a capability check on the save() function found in the ~/includes/admin/class-wc-stripe-admin-user-edit.php file that makes it possible for attackers to configure their account to use other site users unique STRIPE identifier and make purchases with their payment accounts. This affects versions 3.0.0 - 3.3.9.
Recent activity
- 2026-10-22 — latest release on wordpress.org (4.0.19).
- 2026-10-10 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-89100), fixed in 4.0.18.
- 2026-09-09 — Information disclosure disclosed (CVE-2026-80339), fixed in 4.0.12.
- 2026-07-27 — Missing authorization check disclosed (CVE-2026-59530), fixed in 4.0.8.
Get an email when Payment Plugins for Stripe WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Payment Plugins for Stripe WooCommerce (woo-stripe-payment) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Payment Plugins (3 tracked)
Types found in this plugin: Missing authorization (3) · Cross-site scripting (XSS) (1) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woo-stripe-payment (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woo-stripe-payment"><img src="https://laskyr.com/plugins/woo-stripe-payment/badge.svg" alt="Payment Plugins for Stripe WooCommerce vulnerability status"></a>