Plugins · woo-smart-wishlist · data as of 2026-11-04
Is WPC Smart Wishlist for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 6.2.0
- Last updated
- 2026-09-28
- Active installs
- 100,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
WPC Smart Wishlist is a simple but powerful tool that can help your customer save products for buying later. — by WPClever
What to do
- Update to the latest version (6.2.0). Anything older than 5.0.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woo-smart-wishlist --field=version shows what you run; wp plugin update woo-smart-wishlist updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-32407 · published 2026-03-13
Missing authorization check in WPC Smart Wishlist for WooCommerce (5.0.8 and older)
- Affected
- 5.0.8 and older
- Fixed in
- 5.0.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WPClever WPC Smart Wishlist for WooCommerce woo-smart-wishlist allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WPC Smart Wishlist for WooCommerce: from n/a through <= 5.0.8.
medium 4.3 CVE-2025-11742 · published 2025-10-18
Missing authorization check in WPC Smart Wishlist for WooCommerce (5.0.4 and older)
- Affected
- 5.0.4 and older
- Fixed in
- 5.0.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WPC Smart Wishlist for WooCommerce plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'wishlist_quickview' AJAX action in all versions up to, and including, 5.0.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to view other user's wishlist data and information.
medium 5.3 CVE-2025-11518 · published 2025-10-11
Missing authorization check in WPC Smart Wishlist for WooCommerce (5.0.3 and older)
- Affected
- 5.0.3 and older
- Fixed in
- 5.0.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WPC Smart Wishlist for WooCommerce plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 5.0.3 via several wishlist AJAX functions due to missing validation on a user controlled key that is exposed when wishlists are shared. This makes it possible for unauthenticated attackers to empty and add to other user's wishlists, if they have access to the key.
high 8.8 CVE-2023-34386 · published 2023-11-09
Cross-site request forgery (CSRF) in WPC Smart Wishlist for WooCommerce (4.7.1 and older)
- Affected
- 4.7.1 and older
- Fixed in
- 4.7.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in WPClever WPC Smart Wishlist for WooCommerce plugin <= 4.7.1 versions.
medium 6.1 CVE-2022-1465 · published 2022-05-16
Reflected cross-site scripting (XSS) in WPC Smart Wishlist for WooCommerce (older than 2.9.9)
- Affected
- older than 2.9.9
- Fixed in
- 2.9.9
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The WPC Smart Wishlist for WooCommerce WordPress plugin before 2.9.9 does not sanitise and escape a parameter before outputting it back in an attribute via an AJAX action, leading to a Reflected Cross-Site Scripting issue.
medium 5.4 CVE-2022-0397 · published 2022-03-28
Reflected cross-site scripting (XSS) in WPC Smart Wishlist for WooCommerce (older than 2.9.4)
- Affected
- older than 2.9.4
- Fixed in
- 2.9.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The WPC Smart Wishlist for WooCommerce WordPress plugin before 2.9.4 does not sanitise and escape the key parameter before outputting it back in the wishlist_quickview AJAX action's response (available to any authenticated user), leading to a Reflected Cross-Site Scripting
Recent activity
- 2026-09-28 — latest release on wordpress.org (6.2.0).
- 2026-03-13 — Missing authorization check disclosed (CVE-2026-32407), fixed in 5.0.9.
- 2025-10-18 — Missing authorization check disclosed (CVE-2025-11742), fixed in 5.0.5.
- 2025-10-11 — Missing authorization check disclosed (CVE-2025-11518), fixed in 5.0.4.
Get an email when WPC Smart Wishlist for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WPC Smart Wishlist for WooCommerce (woo-smart-wishlist) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by WPClever (8 tracked)
Types found in this plugin: Missing authorization (3) · Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woo-smart-wishlist (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woo-smart-wishlist"><img src="https://laskyr.com/plugins/woo-smart-wishlist/badge.svg" alt="WPC Smart Wishlist for WooCommerce vulnerability status"></a>