Skip to content
Laskyr

Plugins · woo-smart-quick-view · data as of 2026-11-04

Is WPC Smart Quick View for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.4.2)

As of 2026-11-04. 4 issues are on record for older versions; version 4.4.1 or newer fixes all of them that state a fix.

Latest version
4.4.2
Last updated
2026-10-05
Active installs
80,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4

WPC Smart Quick View allows users to get a quick look at products without opening the product page. — by WPClever

What to do

  1. Update to the latest version (4.4.2). Anything older than 4.4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-smart-quick-view --field=version shows what you run; wp plugin update woo-smart-quick-view updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2026-103888 · published 2026-10-03

Reflected cross-site scripting (XSS) in WPC Smart Quick View for WooCommerce (4.4.0 and older)

Affected
4.4.0 and older
Fixed in
4.4.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPC Smart Quick View for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'woosq-redirect' parameter in all versions up to, and including, 4.4.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. The WooCommerce "redirect to cart after add to cart" option must be enabled for the filter that reads the woosq-redirect parameter to execute; however, the ?quick-view= auto-open mechanism means no further user interaction beyond loading the crafted URL is required to trigger script execution.

NVD CVE-2026-103888Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2025-11741 · published 2025-10-18

Information disclosure in WPC Smart Quick View for WooCommerce (4.2.5 and older)

Affected
4.2.5 and older
Fixed in
4.2.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPC Smart Quick View for WooCommerce plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 4.2.5 via the 'woosq_quickview' AJAX endpoint due to insufficient restrictions on which posts can be included. This makes it possible for unauthenticated attackers to extract data from password protected, private, or draft products that they should not have access to.

NVD CVE-2025-11741Wordfence advisoryCode change (fix)

medium 6.4 CVE-2025-8618 · published 2025-08-20

Stored cross-site scripting (XSS) in WPC Smart Quick View for WooCommerce (4.2.1 and older)

Affected
4.2.1 and older
Fixed in
4.2.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPC Smart Quick View for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's woosq_btn shortcode in all versions up to, and including, 4.2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-8618Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 4.4 CVE-2023-6494 · published 2024-04-13

Stored cross-site scripting (XSS) in WPC Smart Quick View for WooCommerce (4.0.2 and older)

Affected
4.0.2 and older
Fixed in
4.0.3 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPC Smart Quick View for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 4.0.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2023-6494Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPC Smart Quick View for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woo-smart-quick-view"><img src="https://laskyr.com/plugins/woo-smart-quick-view/badge.svg" alt="WPC Smart Quick View for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit