Plugins · woo-redsys-gateway-light · data as of 2026-11-04
Is Payment Gateway for Redsys & WooCommerce Lite safe? Known vulnerabilities and latest version
- Latest version
- 7.0.2
- Last updated
- 2026-06-27
- Active installs
- 20,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.0+
Add Redsys Gateway, BIZUM, and Apple/Google Pay redirection to WooCommerce. Lite version of the premium Redsys plugin on WooCommerce.com. — by Jose Conti
What to do
- Update to the latest version (7.0.2). Anything older than 7.0.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woo-redsys-gateway-light --field=version shows what you run; wp plugin update woo-redsys-gateway-light updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-12584 · published 2026-08-06
Security issue in Payment Gateway for Redsys & WooCommerce Lite (older than 7.0.2)
- Affected
- older than 7.0.2
- Fixed in
- 7.0.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by WPScan
Details from the advisory
The Payment Gateway for Redsys & WooCommerce Lite WordPress plugin before 7.0.2 does not verify the authenticity of incoming payment-provider notifications for one of its payment methods before marking orders as paid, allowing unauthenticated attackers to forge a payment-confirmation callback and complete their own orders without paying.
high 7.5 CVE-2026-40741 · published 2026-06-15
Missing authorization check in Payment Gateway for Redsys & WooCommerce Lite (7.0.0 and older)
- Affected
- 7.0.0 and older
- Fixed in
- 7.0.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in Redsys for WooCommerce Light <= 7.0.0 versions.
high 7.5 CVE-2026-5050 · published 2026-04-16
Security issue in Payment Gateway for Redsys & WooCommerce Lite (7.0.0 and older)
- Affected
- 7.0.0 and older
- Fixed in
- 7.0.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Payment Gateway for Redsys & WooCommerce Lite plugin for WordPress is vulnerable to Improper Verification of Cryptographic Signature in versions up to, and including, 7.0.0 due to successful_request() handlers calculating a local signature but not validating Ds_Signature from the request before accepting payment status across the Redsys, Bizum, and Google Pay gateway flows. This makes it possible for unauthenticated attackers to forge payment callback data and mark pending orders as paid when they know a valid order key and order amount, potentially allowing checkout completion and product or service fulfillment without a successful payment.
Recent activity
- 2026-06-27 — latest release on wordpress.org (7.0.2).
- 2026-08-06 — Security issue disclosed (CVE-2026-12584), fixed in 7.0.2.
- 2026-06-15 — Missing authorization check disclosed (CVE-2026-40741), fixed in 7.0.1.
- 2026-04-16 — Security issue disclosed (CVE-2026-5050), fixed in 7.0.1.
Get an email when Payment Gateway for Redsys & WooCommerce Lite has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Payment Gateway for Redsys & WooCommerce Lite (woo-redsys-gateway-light) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Jose Conti (2 tracked)
Types found in this plugin: Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woo-redsys-gateway-light (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woo-redsys-gateway-light"><img src="https://laskyr.com/plugins/woo-redsys-gateway-light/badge.svg" alt="Payment Gateway for Redsys & WooCommerce Lite vulnerability status"></a>