Skip to content
Laskyr

Plugins · woo-rede · data as of 2026-11-04

Is Rede Itaú for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.5.5)

As of 2026-11-04. 5 issues are on record for older versions; version 5.5.3 or newer fixes all of them that state a fix.

Latest version
5.5.5
Last updated
2026-10-23
Active installs
1,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

Payment Gateway for Rede Itaú for WooCommerce - PIX, Credit Card and Debit Cards. — by Link Nacional

What to do

  1. Update to the latest version (5.5.5). Anything older than 5.5.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-rede --field=version shows what you run; wp plugin update woo-rede updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-92428 · published 2026-10-15

Security issue in Rede Itaú for WooCommerce (older than 5.5.3)

Affected
older than 5.5.3
Fixed in
5.5.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by WPScan
Details from the advisory

The Rede Itaú for WooCommerce WordPress plugin before 5.5.3 does not verify the authenticity of a payment gateway webhook before updating an order's status, allowing unauthenticated attackers to change the status of arbitrary WooCommerce orders, including orders that were already paid or completed.

NVD CVE-2026-92428WPScan advisory

medium 5.3 CVE-2026-92429 · published 2026-10-15

Security issue in Rede Itaú for WooCommerce (3.7.1 up to (not including) 5.5.3)

Affected
3.7.1 up to (not including) 5.5.3
Fixed in
5.5.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by WPScan
Details from the advisory

The Rede Itaú for WooCommerce WordPress plugin before 5.5.3 does not verify the authenticity of a payment gateway webhook before updating an order's status, allowing unauthenticated attackers to change the status of arbitrary WooCommerce orders, including marking unpaid orders as paid and cancelling completed orders.

NVD CVE-2026-92429WPScan advisory

medium 5.3 CVE-2026-92430 · published 2026-09-19

Missing authorization check in Rede Itaú for WooCommerce (3.6.1 up to (not including) 5.4.7)

Affected
3.6.1 up to (not including) 5.4.7
Fixed in
5.4.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Rede Itaú for WooCommerce — Payment PIX, Credit Card and Debit WordPress plugin before 5.4.7 does not verify the authenticity of its PIX payment webhook before updating an order's status, allowing unauthenticated attackers to mark a pending order as paid without paying.

NVD CVE-2026-92430WPScan advisory

medium 5.3 CVE-2026-0942 · published 2026-01-16

Missing authorization check in Rede Itaú for WooCommerce (5.1.5 and older)

Affected
5.1.5 and older
Fixed in
5.1.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Rede Itaú for WooCommerce — Payment PIX, Credit Card and Debit plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the clearOrderLogs() function in all versions up to, and including, 5.1.5. This makes it possible for unauthenticated attackers to delete the Rede Order Logs metadata from all WooCommerce orders.

NVD CVE-2026-0942Wordfence advisoryPlugin source

medium 5.3 CVE-2026-0939 · published 2026-01-16

Security issue in Rede Itaú for WooCommerce (5.1.2 and older)

Affected
5.1.2 and older
Fixed in
5.1.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Rede Itaú for WooCommerce plugin for WordPress is vulnerable to order status manipulation due to insufficient verification of data authenticity in all versions up to, and including, 5.1.2. This is due to the plugin failing to verify the authenticity of payment callbacks. This makes it possible for unauthenticated attackers to manipulate WooCommerce order statuses, either marking unpaid orders as paid, or failed.

NVD CVE-2026-0939Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Rede Itaú for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woo-rede"><img src="https://laskyr.com/plugins/woo-rede/badge.svg" alt="Rede Itaú for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit