Skip to content
Laskyr

Plugins · woo-quickview · data as of 2026-11-04

Is Quick View for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.0)

As of 2026-11-04. 2 issues are on record for older versions; version 2.2.18 or newer fixes all of them that state a fix.

Latest version
2.3.0
Last updated
2026-08-20
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

Add a quick view button in the product loop so visitors can quickly view product information in a nice modal without opening the product page. — by ShapedPlugin LLC

What to do

  1. Update to the latest version (2.3.0). Anything older than 2.2.18 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-quickview --field=version shows what you run; wp plugin update woo-quickview updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-12584 · published 2025-11-27

Information disclosure in Quick View for WooCommerce (2.2.17 and older)

Affected
2.2.17 and older
Fixed in
2.2.18 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Quick View for WooCommerce plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 2.2.17 via the 'wqv_popup_content' AJAX endpoint due to insufficient restrictions on which products can be included. This makes it possible for unauthenticated attackers to extract data from private products that they should not have access to.

NVD CVE-2025-12584Wordfence advisoryCode change (fix)

medium 6.5 CVE-2025-58228 · published 2025-09-22

Stored cross-site scripting (XSS) in Quick View for WooCommerce (2.2.16 and older)

Affected
2.2.16 and older
Fixed in
2.2.17
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ShapedPlugin LLC Quick View for WooCommerce woo-quickview allows Stored XSS.This issue affects Quick View for WooCommerce: from n/a through <= 2.2.16.

NVD CVE-2025-58228Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Quick View for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woo-quickview"><img src="https://laskyr.com/plugins/woo-quickview/badge.svg" alt="Quick View for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit