Plugins · woo-products-restricted-users · data as of 2026-11-04
Is Products Restricted Users for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 0.8
- Last updated
- 2026-10-09
- Active installs
- 400+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Restrict product visibility by user or role. Enable per product. — by Javier Carazo
What to do
- Update to the latest version (0.8). Anything older than 0.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woo-products-restricted-users --field=version shows what you run; wp plugin update woo-products-restricted-users updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-107863 · published 2026-10-12
Missing authorization check in Products Restricted Users for WooCommerce (0.7 and older)
- Affected
- 0.7 and older
- Fixed in
- 0.8
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Codection Products Restricted Users for WooCommerce woo-products-restricted-users allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Products Restricted Users for WooCommerce: from n/a through 0.7.
Recent activity
- 2026-10-09 — latest release on wordpress.org (0.8).
- 2026-10-12 — Missing authorization check disclosed (CVE-2026-107863), fixed in 0.8.
Get an email when Products Restricted Users for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Products Restricted Users for WooCommerce (woo-products-restricted-users) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Javier Carazo (2 tracked)
Types found in this plugin: Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woo-products-restricted-users (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woo-products-restricted-users"><img src="https://laskyr.com/plugins/woo-products-restricted-users/badge.svg" alt="Products Restricted Users for WooCommerce vulnerability status"></a>