Plugins · woo-product-table · data as of 2026-11-04
Is Product Table for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 6.1.5
- Last updated
- 2026-10-29
- Active installs
- 5,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Helps you to display your products in a searchable table layout with filters. — by Saiful Islam
What to do
- Update to the latest version (6.1.5). Anything older than 5.0.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woo-product-table --field=version shows what you run; wp plugin update woo-product-table updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2025-12398 · published 2025-12-21
Reflected cross-site scripting (XSS) in Product Table for WooCommerce (5.0.8 and older)
- Affected
- 5.0.8 and older
- Fixed in
- 5.0.9 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Product Table for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'search_key' parameter in all versions up to, and including, 5.0.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
high 7.1 CVE-2025-22307 · published 2025-01-09
Reflected cross-site scripting (XSS) in Product Table for WooCommerce (4.0.3 and older)
- Affected
- 4.0.3 and older
- Fixed in
- 5.0.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Saiful Islam Product Table for WooCommerce woo-product-table allows Reflected XSS.This issue affects Product Table for WooCommerce: from n/a through <= 4.0.3.
high 7.5 CVE-2024-10813 · published 2024-11-23
Information disclosure in Product Table for WooCommerce (3.5.1 and older)
- Affected
- 3.5.1 and older
- Fixed in
- 3.5.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Product Table for WooCommerce by CodeAstrology (wooproducttable.com) plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.5.1 via the var_dump_table parameter. This makes it possible for unauthenticated attackers var data.
NVD CVE-2024-10813Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-29 — latest release on wordpress.org (6.1.5).
- 2025-12-21 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-12398), fixed in 5.0.9.
- 2025-01-09 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-22307), fixed in 5.0.0.
- 2024-11-23 — Information disclosure disclosed (CVE-2024-10813), fixed in 3.5.2.
Get an email when Product Table for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Product Table for WooCommerce (woo-product-table) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Saiful Islam (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woo-product-table (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woo-product-table"><img src="https://laskyr.com/plugins/woo-product-table/badge.svg" alt="Product Table for WooCommerce vulnerability status"></a>