Skip to content
Laskyr

Plugins · woo-product-category-discount · data as of 2026-11-04

Is Simple Discount Rules for Woocommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.19)

As of 2026-11-04. 2 issues are on record for older versions; version 5.19 or newer fixes all of them that state a fix.

Latest version
5.19
Last updated
2026-09-16
Active installs
4,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8

Simple Discount Rules for Woocommerce allows administrator to add and remove discount to products based on Category. — by Vidish

What to do

  1. Update to the latest version (5.19). Anything older than 5.19 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-product-category-discount --field=version shows what you run; wp plugin update woo-product-category-discount updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.6 CVE-2026-96828 · published 2026-09-30

SQL injection in Simple Discount Rules for Woocommerce (5.18 and older)

Affected
5.18 and older
Fixed in
5.19
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Administrator SQL Injection in Category Discount Woocommerce <= 5.18 versions.

NVD CVE-2026-96828Patchstack advisory

medium 5.3 CVE-2024-0617 · published 2024-01-25

Missing authorization check in Simple Discount Rules for Woocommerce (4.12 and older)

Affected
4.12 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Category Discount Woocommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the wpcd_save_discount() function in all versions up to, and including, 4.12. This makes it possible for unauthenticated attackers to modify product category discounts that could lead to loss of revenue.

NVD CVE-2024-0617Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Simple Discount Rules for Woocommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woo-product-category-discount"><img src="https://laskyr.com/plugins/woo-product-category-discount/badge.svg" alt="Simple Discount Rules for Woocommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit