Skip to content
Laskyr

Plugins · woo-product-bundle · data as of 2026-11-04

Is WPC Product Bundles for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (8.7.8)

As of 2026-11-04. 4 issues are on record for older versions; version 8.6.7 or newer fixes all of them that state a fix.

Latest version
8.7.8
Last updated
2026-10-26
Active installs
30,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4

WPC Product Bundles is a plugin that helps you bundle a few products, offer them at a discount, and watch the sales go up! — by WPClever

What to do

  1. Update to the latest version (8.7.8). Anything older than 8.6.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-product-bundle --field=version shows what you run; wp plugin update woo-product-bundle updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-93836 · published 2026-09-22

Stored cross-site scripting (XSS) in WPC Product Bundles for WooCommerce (8.6.6 and older)

Affected
8.6.6 and older
Fixed in
8.6.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPC Product Bundles for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'qty' parameter in all versions up to, and including, 8.6.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The float cast used during quantity validation allows a numeric-prefixed payload such as '1<img src=x onerror=...>' to pass validation while retaining its malicious HTML, which is then stored verbatim in order item metadata under the '_woosb_ids' key.

NVD CVE-2026-93836Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2026-48883 · published 2026-06-15

Missing authorization check in WPC Product Bundles for WooCommerce (8.5.3 and older)

Affected
8.5.3 and older
Fixed in
8.5.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in WPC Product Bundles for WooCommerce <= 8.5.3 versions.

NVD CVE-2026-48883Patchstack advisory

medium 4.3 CVE-2026-32406 · published 2026-03-13

Missing authorization check in WPC Product Bundles for WooCommerce (8.4.5 and older)

Affected
8.4.5 and older
Fixed in
8.4.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WPClever WPC Product Bundles for WooCommerce woo-product-bundle allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WPC Product Bundles for WooCommerce: from n/a through <= 8.4.5.

NVD CVE-2026-32406Patchstack advisory

high 8.8 CVE-2023-52127 · published 2024-01-05

Cross-site request forgery (CSRF) in WPC Product Bundles for WooCommerce (7.3.1 and older)

Affected
7.3.1 and older
Fixed in
7.3.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in WPClever WPC Product Bundles for WooCommerce.This issue affects WPC Product Bundles for WooCommerce: from n/a through 7.3.1.

NVD CVE-2023-52127Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPC Product Bundles for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woo-product-bundle"><img src="https://laskyr.com/plugins/woo-product-bundle/badge.svg" alt="WPC Product Bundles for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit