Plugins · woo-poly-integration · data as of 2026-11-04
Is Hyyan Integration for WooCommerce and Polylang safe? Known vulnerabilities and latest version
- Latest version
- 1.6.0
- Last updated
- 2026-10-18
- Active installs
- 8,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Connect WooCommerce and Polylang for a multilingual store. — by Hyyan Abo Fakher
What to do
- Update to the latest version (1.6.0). Anything older than 1.6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woo-poly-integration --field=version shows what you run; wp plugin update woo-poly-integration updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-101926 · published 2026-10-14
SQL injection in Hyyan Integration for WooCommerce and Polylang (1.5.0 and older)
- Affected
- 1.5.0 and older
- Fixed in
- 1.6.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Hyyan WooCommerce Polylang Integration plugin for WordPress is vulnerable to SQL Injection via the 'variation_ids' parameter of the 'woocommerce_remove_variations' AJAX action in versions up to, and including, 1.5.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
medium 6.5 CVE-2026-24585 · published 2026-01-23
Missing authorization check in Hyyan Integration for WooCommerce and Polylang (1.5.0 and older)
- Affected
- 1.5.0 and older
- Fixed in
- 1.6.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Hyyan Abo Fakher Hyyan WooCommerce Polylang Integration woo-poly-integration allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Hyyan WooCommerce Polylang Integration: from n/a through <= 1.5.0.
Recent activity
- 2026-10-18 — latest release on wordpress.org (1.6.0).
- 2026-10-14 — SQL injection disclosed (CVE-2026-101926), fixed in 1.6.0.
- 2026-01-23 — Missing authorization check disclosed (CVE-2026-24585), fixed in 1.6.0.
Get an email when Hyyan Integration for WooCommerce and Polylang has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Hyyan Integration for WooCommerce and Polylang (woo-poly-integration) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: SQL injection (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woo-poly-integration (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woo-poly-integration"><img src="https://laskyr.com/plugins/woo-poly-integration/badge.svg" alt="Hyyan Integration for WooCommerce and Polylang vulnerability status"></a>