Skip to content
Laskyr

Plugins · woo-permalink-manager · data as of 2026-11-04

Is Premmerce Permalink Manager for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.4)

As of 2026-11-04. 2 issues are on record for older versions; version 2.3.16 or newer fixes all of them that state a fix.

Latest version
2.4.4
Last updated
2026-10-31
Active installs
40,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Premmerce Permalink Manager for WooCommerce allows you to change WooCommerce permalink and remove product and product_category slugs from the URL. — by Premmerce

What to do

  1. Update to the latest version (2.4.4). Anything older than 2.3.16 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-permalink-manager --field=version shows what you run; wp plugin update woo-permalink-manager updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-97272 · published 2026-09-30

Cross-site scripting (XSS) in Premmerce Permalink Manager for WooCommerce (2.3.13 and older)

Affected
2.3.13 and older
Fixed in
2.3.16
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Premmerce Permalink Manager for WooCommerce <= 2.3.13 versions.

NVD CVE-2026-97272Patchstack advisory

high 8.3 CVE-2024-27971 · published 2024-05-17

File inclusion in Premmerce Permalink Manager for WooCommerce (2.3.10 and older)

Affected
2.3.10 and older
Fixed in
2.3.11
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Premmerce Premmerce Permalink Manager for WooCommerce woo-permalink-manager.This issue affects Premmerce Permalink Manager for WooCommerce: from n/a through <= 2.3.10.

NVD CVE-2024-27971Patchstack advisoryPatchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Premmerce Permalink Manager for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woo-permalink-manager"><img src="https://laskyr.com/plugins/woo-permalink-manager/badge.svg" alt="Premmerce Permalink Manager for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit