Skip to content
Laskyr

Plugins · woo-payment-gateway · data as of 2026-11-04

Is Payment Plugins Braintree For WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.86)

As of 2026-11-04. 1 issue is on record for older versions; version 3.2.79 or newer fixes all of them that state a fix.

Latest version
3.2.86
Last updated
2026-10-09
Active installs
2,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Accept Credit Cards, PayPal, PayPal Credit, Google Pay, ApplePay, Venmo, and Local Payments like iDEAL all in one plugin for free! — by Payment Plugins

What to do

  1. Update to the latest version (3.2.86). Anything older than 3.2.79 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-payment-gateway --field=version shows what you run; wp plugin update woo-payment-gateway updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2025-12903 · published 2025-11-12

Missing authorization check in Payment Plugins Braintree For WooCommerce (3.2.78 and older)

Affected
3.2.78 and older
Fixed in
3.2.79 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Payment Plugins Braintree For WooCommerce plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the wc-braintree/v1/3ds/vaulted_nonce REST API endpoint in all versions up to, and including, 3.2.78. This is due to the endpoint being registered with permission_callback set to __return_true and processing user-supplied token IDs without verifying ownership or authentication. This makes it possible for unauthenticated attackers to retrieve payment method nonces for any stored payment token in the system, which can be used to create fraudulent transactions, charge customer credit cards, or attach payment methods to other subscriptions.

NVD CVE-2025-12903Wordfence advisoryCode change (fix)developer.wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Payment Plugins Braintree For WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woo-payment-gateway"><img src="https://laskyr.com/plugins/woo-payment-gateway/badge.svg" alt="Payment Plugins Braintree For WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit