Skip to content
Laskyr

Plugins · woo-order-splitter · data as of 2026-11-04

Is Order Splitter for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.3.9)

As of 2026-11-04. 2 issues are on record for older versions; version 5.3.6 or newer fixes all of them that state a fix.

Latest version
5.3.9
Last updated
2026-10-30
Active installs
300+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

A great plugin to split WooCommerce orders. You can duplicate orders as well. — by Fahad Mahmood

What to do

  1. Update to the latest version (5.3.9). Anything older than 5.3.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-order-splitter --field=version shows what you run; wp plugin update woo-order-splitter updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-12075 · published 2026-02-18

Missing authorization check in Order Splitter for WooCommerce (5.3.5 and older)

Affected
5.3.5 and older
Fixed in
5.3.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Order Splitter for WooCommerce plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'wos_troubleshooting' AJAX endpoint in all versions up to, and including, 5.3.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, to view information pertaining to other user's orders.

NVD CVE-2025-12075Wordfence advisoryCode change (fix)

high 8.5 CVE-2025-31089 · published 2025-04-01

SQL injection in Order Splitter for WooCommerce (5.3.0 and older)

Affected
5.3.0 and older
Fixed in
5.3.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Fahad Mahmood Order Splitter for WooCommerce woo-order-splitter allows SQL Injection.This issue affects Order Splitter for WooCommerce: from n/a through <= 5.3.0.

NVD CVE-2025-31089Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Order Splitter for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woo-order-splitter"><img src="https://laskyr.com/plugins/woo-order-splitter/badge.svg" alt="Order Splitter for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit