Plugins · woo-mailerlite · data as of 2026-11-04
Is MailerLite safe? Known vulnerabilities and latest version
- Latest version
- 3.1.29
- Last updated
- 2026-10-29
- Active installs
- 30,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 6.8.12 · PHP 7.2.5+
Powerful e-commerce email marketing tools that are easy to use. Grow your store with automated emails, pop-ups, product blocks, sales tracking + more. — by MailerLite
What to do
- Update to the latest version (3.1.29). Anything older than 3.1.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woo-mailerlite --field=version shows what you run; wp plugin update woo-mailerlite updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.3 CVE-2025-67945 · published 2026-01-22
SQL injection in MailerLite (3.1.2 and older)
- Affected
- 3.1.2 and older
- Fixed in
- 3.1.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in MailerLite MailerLite – WooCommerce integration woo-mailerlite allows SQL Injection.This issue affects MailerLite – WooCommerce integration: from n/a through <= 3.1.2.
medium 6.5 CVE-2026-1000 · published 2026-01-16
Missing authorization check in MailerLite (3.1.3 and older)
- Affected
- 3.1.3 and older
- Fixed in
- 3.1.4 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The MailerLite - WooCommerce integration plugin for WordPress is vulnerable to unauthorized data modification and deletion in all versions up to, and including, 3.1.3. This is due to missing capability checks on the resetIntegration() function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to reset the plugin's integration settings, delete all plugin options, and drop the plugin's database tables (woo_mailerlite_carts and woo_mailerlite_jobs), resulting in complete loss of plugin data including customer abandoned cart information and sync job history.
NVD CVE-2026-1000Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2023-52227 · published 2024-06-11
Missing authorization check in MailerLite (2.0.8 and older)
- Affected
- 2.0.8 and older
- Fixed in
- 2.0.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in MailerLite MailerLite – WooCommerce integration.This issue affects MailerLite – WooCommerce integration: from n/a through 2.0.8.
high 8.8 CVE-2023-52223 · published 2024-02-28
Cross-site request forgery (CSRF) in MailerLite (2.0.8 and older)
- Affected
- 2.0.8 and older
- Fixed in
- 2.0.9
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in MailerLite MailerLite – WooCommerce integration.This issue affects MailerLite – WooCommerce integration: from n/a through 2.0.8.
Recent activity
- 2026-10-29 — latest release on wordpress.org (3.1.29).
- 2026-01-22 — SQL injection disclosed (CVE-2025-67945), fixed in 3.1.3.
- 2026-01-16 — Missing authorization check disclosed (CVE-2026-1000), fixed in 3.1.4.
- 2024-06-11 — Missing authorization check disclosed (CVE-2023-52227), fixed in 2.0.9.
Get an email when MailerLite has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for MailerLite (woo-mailerlite) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by MailerLite (2 tracked)
Types found in this plugin: Missing authorization (2) · SQL injection (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woo-mailerlite (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woo-mailerlite"><img src="https://laskyr.com/plugins/woo-mailerlite/badge.svg" alt="MailerLite vulnerability status"></a>