Skip to content
Laskyr

Plugins · woo-customers-manager · data as of 2026-11-04

Is Premmerce WooCommerce Customers Manager safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.18)

As of 2026-11-04. 1 issue is on record for older versions; version 1.1.15 or newer fixes all of them that state a fix.

Latest version
1.1.18
Last updated
2026-10-31
Active installs
700+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

This plugin extends the standard user list and the edit user page in WordPress and adds the customer data from WooCommerce. — by Premmerce

What to do

  1. Update to the latest version (1.1.18). Anything older than 1.1.15 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-customers-manager --field=version shows what you run; wp plugin update woo-customers-manager updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2025-13369 · published 2026-01-07

Reflected cross-site scripting (XSS) in Premmerce WooCommerce Customers Manager (1.1.14 and older)

Affected
1.1.14 and older
Fixed in
1.1.15 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Premmerce WooCommerce Customers Manager plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'money_spent_from', 'money_spent_to', 'registered_from', and 'registered_to' parameters in all versions up to, and including, 1.1.14 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick an administrator into performing an action such as clicking on a link.

NVD CVE-2025-13369Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Premmerce WooCommerce Customers Manager vulnerability status badge
<a href="https://laskyr.com/plugins/woo-customers-manager"><img src="https://laskyr.com/plugins/woo-customers-manager/badge.svg" alt="Premmerce WooCommerce Customers Manager vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit