Skip to content
Laskyr

Plugins · woo-combo-offers · data as of 2026-11-04

Is Combo Offers WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.5)

As of 2026-11-04. 1 issue is on record for older versions; version 4.3 or newer fixes all of them that state a fix.

Latest version
4.5
Last updated
2026-02-17
Active installs
2,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11

Combo Offers WooCommerce is a plugin help you bundle a few products with your custom quantity, offer them at a discount and watch the sales go up! — by Vidish

What to do

  1. Update to the latest version (4.5). Anything older than 4.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-combo-offers --field=version shows what you run; wp plugin update woo-combo-offers updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-69088 · published 2025-12-30

Cross-site scripting (XSS) in Combo Offers WooCommerce (4.2 and older)

Affected
4.2 and older
Fixed in
4.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Vidish Combo Offers WooCommerce woo-combo-offers allows DOM-Based XSS.This issue affects Combo Offers WooCommerce: from n/a through <= 4.2.

NVD CVE-2025-69088Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Combo Offers WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woo-combo-offers"><img src="https://laskyr.com/plugins/woo-combo-offers/badge.svg" alt="Combo Offers WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit