Skip to content
Laskyr

Plugins · woo-checkout-field-editor-pro · data as of 2026-11-01

Is Checkout Field Editor (Checkout Manager) for W… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.1)

As of 2026-11-01. 3 issues are on record for older versions; version 2.1.8 or newer fixes all of them that state a fix.

Latest version
2.2.1
Last updated
2026-10-30
Active installs
400,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Checkout Field Editor for WooCommerce – The best WooCommerce checkout manager plugin to manage checkout fields in both Classic & Block Checkout. — by ThemeHigh

What to do

  1. Update to the latest version (2.2.1). Anything older than 2.1.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-checkout-field-editor-pro --field=version shows what you run; wp plugin update woo-checkout-field-editor-pro updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-3231 · published 2026-03-11

Stored cross-site scripting (XSS) in Checkout Field Editor (Checkout Manager) for W… (2.1.7 and older)

Affected
2.1.7 and older
Fixed in
2.1.8 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Checkout Field Editor (Checkout Manager) for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via custom radio and checkboxgroup field values submitted through the WooCommerce Block Checkout Store API in all versions up to, and including, 2.1.7. This is due to the `prepare_single_field_data()` method in `class-thwcfd-block-order-data.php` first escaping values with `esc_html()` then immediately reversing the escaping with `html_entity_decode()` for radio and checkboxgroup field types, combined with a permissive `wp_kses()` allowlist in `get_allowed_html()` that explicitly permits the `<select>` element with the `onchange` event handler attribute. This makes it possible for unauthenticated attackers to inject arbitrary web scripts via the Store API checkout endpoint that execute when an administrator views the order details page.

NVD CVE-2026-3231Wordfence advisoryCode change (fix)research.cleantalk.orgPlugin source

medium 6.1 CVE-2024-8499 · published 2024-10-04

Reflected cross-site scripting (XSS) in Checkout Field Editor (Checkout Manager) for W… (2.0.3 and older)

Affected
2.0.3 and older
Fixed in
2.0.4 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Checkout Field Editor (Checkout Manager) for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘render_review_request_notice’ function in all versions up to, and including, 2.0.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-8499Wordfence advisoryCode change (fix)Plugin source

high 7.2 CVE-2022-3490 · published 2022-11-28

PHP object injection in Checkout Field Editor (Checkout Manager) for W… (older than 1.8.0)

Affected
older than 1.8.0
Fixed in
1.8.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Checkout Field Editor (Checkout Manager) for WooCommerce WordPress plugin before 1.8.0 unserializes user input provided via the settings, which could allow high privilege users such as admin to perform PHP Object Injection when a suitable gadget is present

NVD CVE-2022-3490WPScan advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Checkout Field Editor (Checkout Manager) for W… vulnerability status badge
<a href="https://laskyr.com/plugins/woo-checkout-field-editor-pro"><img src="https://laskyr.com/plugins/woo-checkout-field-editor-pro/badge.svg" alt="Checkout Field Editor (Checkout Manager) for W… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit