Skip to content
Laskyr

Plugins · woo-blocker-lite-prevent-fake-orders-and-blacklist-fraud-customers · data as of 2026-11-04

Is Fraud Prevention For WooCommerce and EDD safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.6)

As of 2026-11-04. 4 issues are on record for older versions; version 2.3.6 or newer fixes all of them that state a fix.

Latest version
2.3.6
Last updated
2026-10-22
Active installs
4,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

It will Prevent fake orders and Blacklist fraud customers of your store. — by Dotstore

What to do

  1. Update to the latest version (2.3.6). Anything older than 2.3.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-blocker-lite-prevent-fake-orders-and-blacklist-fraud-customers --field=version shows what you run; wp plugin update woo-blocker-lite-prevent-fake-orders-and-blacklist-fraud-customers updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-118072 · published 2026-10-30

Missing authorization check in Fraud Prevention For WooCommerce and EDD (older than 2.3.6)

Affected
older than 2.3.6
Fixed in
2.3.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Fraud Prevention For WooCommerce and EDD WordPress plugin before 2.3.6 does not check that a user is allowed to manage orders before letting them add an order's customer details to the store's fraud blacklist, which could allow users with the Subscriber role and above to prevent arbitrary legitimate customers from placing orders.

NVD CVE-2026-118072WPScan advisory

high 7.5 CVE-2026-25443 · published 2026-03-19

Missing authorization check in Fraud Prevention For WooCommerce and EDD (2.3.3 and older)

Affected
2.3.3 and older
Fixed in
2.3.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Dotstore Fraud Prevention For Woocommerce woo-blocker-lite-prevent-fake-orders-and-blacklist-fraud-customers allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Fraud Prevention For Woocommerce: from n/a through <= 2.3.3.

NVD CVE-2026-25443Patchstack advisory

medium 4.3 CVE-2026-24553 · published 2026-01-23

Information disclosure in Fraud Prevention For WooCommerce and EDD (2.3.2 and older)

Affected
2.3.2 and older
Fixed in
2.3.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in Dotstore Fraud Prevention For Woocommerce woo-blocker-lite-prevent-fake-orders-and-blacklist-fraud-customers allows Retrieve Embedded Sensitive Data.This issue affects Fraud Prevention For Woocommerce: from n/a through <= 2.3.2.

NVD CVE-2026-24553Patchstack advisory

medium 6.5 CVE-2023-39159 · published 2023-10-03

Cross-site request forgery (CSRF) in Fraud Prevention For WooCommerce and EDD (2.1.5 and older)

Affected
2.1.5 and older
Fixed in
2.1.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in theDotstore Fraud Prevention For Woocommerce plugin <= 2.1.5 versions.

NVD CVE-2023-39159Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Fraud Prevention For WooCommerce and EDD vulnerability status badge
<a href="https://laskyr.com/plugins/woo-blocker-lite-prevent-fake-orders-and-blacklist-fraud-customers"><img src="https://laskyr.com/plugins/woo-blocker-lite-prevent-fake-orders-and-blacklist-fraud-customers/badge.svg" alt="Fraud Prevention For WooCommerce and EDD vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit