Skip to content
Laskyr

Plugins · woo-advanced-shipment-tracking · data as of 2026-11-04

Is Advanced Shipment Tracking for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.0.6)

As of 2026-11-04. 4 issues are on record for older versions; version 4.0.1 or newer fixes all of them that state a fix.

Latest version
4.0.6
Last updated
2026-10-29
Active installs
70,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

The #1 WooCommerce shipment tracking plugin. Add tracking numbers, auto-update order status & send branded shipping notifications. 1010+ carriers. — by Zorem

What to do

  1. Update to the latest version (4.0.6). Anything older than 4.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-advanced-shipment-tracking --field=version shows what you run; wp plugin update woo-advanced-shipment-tracking updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-120558 · published 2026-11-03

SQL injection in Advanced Shipment Tracking for WooCommerce (3.9 and older)

Affected
3.9 and older
Fixed in
3.9.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Advanced Shipment Tracking for WooCommerce plugin for WordPress is vulnerable to SQL Injection via the `tracking_provider` parameter of the `POST /wp-json/wc-ast/v3/orders/<order_id>/shipment-trackings` REST endpoint in all versions up to, and including, 3.9. This is due to insufficient escaping on the user-supplied parameter and lack of sufficient preparation on the existing SQL query in `WC_Advanced_Shipment_Tracking_Admin::get_provider_slug_from_name()` — the value is concatenated directly into the format string of `$wpdb->prepare()` rather than bound as a parameter, bypassing parameterised-query protections. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to append additional SQL queries into the already-existing query that can be used to extract sensitive information from the database.

NVD CVE-2026-120558Wordfence advisoryCode change (fix)wordpress.orgPlugin source

high 7.6 CVE-2026-57773 · published 2026-07-13

SQL injection in Advanced Shipment Tracking for WooCommerce (4.0 and older)

Affected
4.0 and older
Fixed in
4.0.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Zorem Advanced Shipment Tracking for WooCommerce woo-advanced-shipment-tracking allows Blind SQL Injection.This issue affects Advanced Shipment Tracking for WooCommerce: from n/a through <= 4.0.

NVD CVE-2026-57773Patchstack advisory

medium 6.5 CVE-2021-4347 · published 2023-06-07

Missing authorization check in Advanced Shipment Tracking for WooCommerce (3.2.6 and older)

Affected
3.2.6 and older
Fixed in
3.5.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The function update_shipment_status_email_status_fun in the plugin Advanced Shipment Tracking for WooCommerce in versions up to 3.2.6 is vulnerable to authenticated arbitrary options update. The function allows attackers (including those at customer level) to update any WordPress option in the database. Version 3.2.5 was initially released as a fix, but doesn't fully address the issue.

NVD CVE-2021-4347Wordfence advisoryblog.nintechnet.com

high 8.8 CVE-2022-41635 · published 2023-05-25

Cross-site request forgery (CSRF) in Advanced Shipment Tracking for WooCommerce (3.5.2 and older)

Affected
3.5.2 and older
Fixed in
3.5.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Zorem Advanced Shipment Tracking for WooCommerce plugin <= 3.5.2 versions.

NVD CVE-2022-41635Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Advanced Shipment Tracking for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woo-advanced-shipment-tracking"><img src="https://laskyr.com/plugins/woo-advanced-shipment-tracking/badge.svg" alt="Advanced Shipment Tracking for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit